This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 189971

Summary: rescue CAN see disk, anaconda does NOT
Product: [Fedora] Fedora Documentation Reporter: Bob Gustafson <bobgus>
Component: install-guideAssignee: Paul W. Frields <stickster>
Status: CLOSED RAWHIDE QA Contact: Paul W. Frields <stickster>
Severity: high Docs Contact:
Priority: medium    
Version: develCC: bobgus
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-19 00:38:30 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 161575    
Attachments:
Description Flags
anaconda.log - after all of the actions described above
none
syslog -- after all of the actions described above
none
dmesg taken just after initial login by user1 on Fedora FOUR
none
install.log from install of Fedora FOUR on this hardware
none
install.log.syslog for Fedora FOUR install on same hardware
none
anaconda.log for correct install run of FC5
none
syslog from correct install run of FC5 none

Description Bob Gustafson 2006-04-26 07:35:12 EDT
Description of problem:

I am trying to install FC5 on raid/lvm. I have a two disk system and have
partitioned both disks identically (100m, 4g, 69g) and want to go with (boot,
swap, root) on (raid, raid, raid-lvm)

To configure raid/lvm in anaconda, I need to see both disks. Anaconda only sees
one of the disks. (sdb)

However, if I go into 'linux rescue', and do 'cat /proc/partitions', I see the
following:

7     0      70420 loop0
8     0  195360984 sda
8     1  195358401 sda1
8    16   71687372 sdb
8    17     104391 sdb1
8    18    3911827 sdb2
8    19   67665780 sdb3
8    32   71687372 sdc
8    33     104391 sdc1
8    34    3911827 sdc2
8    35   67665780 sdc3

I have gone through the mdadm --create process successfully to create /dev/md0,
/dev/md1, /dev/md2, and also the lvm; pvcreate, vgcreate, lvcreate processes to
create an lvm volue  /dev/rootvg/root. All this has been done in 'linux rescue'
mode.

All of this is for nought because when I exit the rescue and go into the real
install, I see only sdb. With only one disk, I cannot go any further..

Version-Release number of selected component (if applicable):

FC5 final set of CD roms

How reproducible:

Unfortunately, has happened about 5 times so far, as I try various wrinkles.

Steps to Reproduce:
1. go into 'linux rescue' mode
2. partition disks, create raid volumes, create lvm volume
3. exit from 'linux rescue'
4. request 'custom' disk layout
5. only see one disk (sdb) and cannot create raid/lvm
  
Actual results:

Only see one disk in custom disk layouts.

Expected results:

Would like to see both disks, so I can go through the raid/lvm creation in the
installer, prior to installing FC5

Additional info:

When I remove one of the disks (presumably the 'good' one) and do straight linux
install, the installer does not find any disks.  However, 'linux rescue' sees it
fine (cat /proc/partitions).
Comment 1 Jeremy Katz 2006-04-26 14:37:54 EDT
Can you grab /tmp/anaconda.log and /tmp/syslog from within the installer?
Comment 2 Bob Gustafson 2006-04-26 16:47:55 EDT
How do I do that?

I can do it with 'linux rescue' - send through network, but

I don't know how to do it in the installer. There I just click on the buttons -
not much in the way of command line interaction. Or is there a way?
Comment 3 Jeremy Katz 2006-04-26 16:50:37 EDT
If you switch to tty2, you'll have a shell and can bring up the network or copy
to removable storage.
Comment 4 Bob Gustafson 2006-04-26 17:08:16 EDT
Hmm, might I use the shell to 'mdadm --create ...' etc?

I looked in anaconda.log and syslog.

Seems to be something left over from install run. Is this possible.

Should I wipe what is there and start anew from the installer and tty2 ?
Comment 5 Bob Gustafson 2006-04-26 22:30:39 EDT
OK, did the whole job, but am having same bum results.

Starting from the beginning

0) selecting 'linux text' mode (may not make a difference)
1) boot with cdrom #1 up to the step where it welcomes the user, just after the
English and keyboard (us) question (early in the process anyway)

2) Go into alternate screens

ALT F1 - gets back to the installer screen
ALT F2 - gets a shell (tty2). Don't say exit, because you don't come back
ALT F3 - a tail view of /tmp/anaconda.log
ALT F4 - a tail view of /tmp/syslog

3) In the tty2 screen, do the following

/usr/sbin/mdadm --create /dev/md0 -l 1 -n 2 /dev/sdb1 /dev/sdc1
/usr/sbin/mdadm --create /dev/md1 -l 1 -n 2 /dev/sdb2 /dev/sdc2
/usr/sbin/mdadm --create /dev/md2 -l 1 -n 2 /dev/sdb3 /dev/sdc3

4) Check for completion of md[n] assemble (takes about 20 minute) by executing
the following command until the display shows that all 3 arrays are active

cat /proc/mdstat

4) Check/create the LVM phys vol, group, and logical volume

execute:
/usr/sbin/lvm
File descriptor 101 left open    --- (garbage output?)
File descriptor 107 left open    --- (garbage output?)

lvm> pvdisplay

... good looking output, includes VG Name  rootvg

If volume shows pv already created, then go on, otherwise create p volume
--- conditional lvm> pvcreate /dev/md2

lvm> vgdisplay

--- good looking output, includes VG Status   resizable

If volume shows rootvg already create, then go on, otherwise create

Now, check for logical volume

lvm> lvdisplay

--- goog looking output, includes LV Name  /dev/rootvg/root

Note, if this output includes LV Status  NOT available,
then you need to do

lvm> vgchange -a y

and check again.

lvm> lvdisplay

--- good looking output, including LV Status   available

5) Now, switch back to the Installer screen (ALT F1) and continue answering the
questions (English, keyboard )?

6) You will see that when you come to the 'Partitioning Type' screen, only the
sdb disk is shown - you cannot go on from here because you only have one disk.
Need two to RAID.

7) Jumping back to the ALT F2 screen and executing

lvm> lvdisplay

You (I anyway) see that the /dev/rootvg/root has changed status to:

LV Status    NOT available

(Curious..)

anaconda.log and syslog are given as attachments to follow
(These were copied off using rsync, once the eth0 interface was configured by
hand with /usr/sbin/ifconfig)
Comment 6 Bob Gustafson 2006-04-26 22:33:28 EDT
Created attachment 128281 [details]
anaconda.log - after all of the actions described above
Comment 7 Bob Gustafson 2006-04-26 22:34:41 EDT
Created attachment 128283 [details]
syslog   -- after all of the actions described above
Comment 8 Jeremy Katz 2006-04-27 21:22:57 EDT
Is one of these a firewire or USB disk?  We don't support installing to them by
default...
Comment 9 Bob Gustafson 2006-04-28 01:24:21 EDT
There may have been a firewire disk attached to the box, but sometime in that
process my keyboard fell off the tower and hit the firewire box. It started to
make a funny sound, so I turned it off. I don't know whether that was before or
after the attached logs. In either case, firebox was not used.

There was no storage attached to a USB port.

At one time in my earlier experiments, I attached my camera via USB. I should
have been able to see the memory (0.5Gb), but did not. Camera was not attached
for above logs.
Comment 10 Bob Gustafson 2006-04-28 01:27:38 EDT
The two disks sdb and sdc are 73Gb Seagate SCSI disks. Identical numbers of
blocks in each.
Comment 11 Bob Gustafson 2006-04-28 01:52:35 EDT
The sdc disk originally had rh9 installed. When I wanted to go back to rh9 from
fc[2345] I would just unplug both disks and swap them in their SCA slots. I
could then mount the fc disk from rh9.

The idea of getting the second disk was to go to RAID1. Because I needed two
(blank) disks to go to RAID at fc install time, this only happened when I got
another (firebox) 200G disk to copy stuff to.

Right now, this whole .. machine is dead in the water.

-----

I do have another machine, much more modest, with two 36G disks running RAID1
FC5. I had a third 4G scsi disk on that machine which was (is?) the grub host.

So I know what I am trying to do is possible..
Comment 12 Bob Gustafson 2006-04-30 08:24:45 EDT
Well, that's pretty interesting.

If I boot up the machine using Fedora Core FOUR disc 1, going through the
English, English us, to the Disk Setup window:

Both SCSI disks show (sda, sdb), the LVM Volume Group rootvg->root is shown, all
3 RAID Devices are shown /dev/md0, /dev/md1, /dev/md2 and the rootvg is shown on
the Mount Point/RAID/Volume column of /dev/md2, just as it should be..

A difference between this and FC5 is that sda on FC5 seems to be the cdrom drive
(maybe the loop device - neet to go back and look). The first (and only) SCSI
disk in the FC5 install is sdb  - it does not see the other disk, and therefore
cannot start up the RAID devices.

I think I will go forward and install FC4 on this system and then go back and
try to install FC5. Perhaps something will have changed (??).
Comment 13 Bob Gustafson 2006-04-30 12:55:58 EDT
So far, so good. Installed FC4 and am running from it now. Note this is FC FOUR,
not the latest and greatest FC five.

Attached are the dmesg, anaconda-ks.cfg, install.log, and install.log.syslog for
this installation on this hardware of FC4
Comment 14 Bob Gustafson 2006-04-30 12:58:40 EDT
Created attachment 128414 [details]
dmesg taken just after initial login by user1 on Fedora FOUR

This should show the same hardware as shown in the FC5 attempts. Note that the
firewire disk is still turned OFF.
Comment 15 Bob Gustafson 2006-04-30 13:02:06 EDT
Created attachment 128415 [details]
install.log from install of Fedora FOUR on this hardware
Comment 16 Bob Gustafson 2006-04-30 13:03:01 EDT
Created attachment 128416 [details]
install.log.syslog for Fedora FOUR install on same hardware
Comment 17 Bob Gustafson 2006-04-30 13:08:13 EDT
The attach process for anaconda-ks.cfg said file was empty. It actually has 1835
bytes.

This was after copying to /home/user1 and chown user1:user1

Directory is shown below:

[root@hoho2 ~]# ls -l
total 124
-rw-r--r--  1 user1 user1  1835 Apr 30 11:56 anaconda-ks.cfg
-rw-r--r--  1 user1 user1 25472 Apr 30 11:57 dmesg
-rw-r--r--  1 user1 user1 61933 Apr 30 11:34 install.log
-rw-r--r--  1 user1 user1  5541 Apr 30 11:34 install.log.syslog
[root@hoho2 ~]#

One more of the install puzzles..

I do like the ALT F2, F3, F4 of the new FC5 installer.

--------
Now for retry of FC5 install..
Comment 18 Bob Gustafson 2006-04-30 14:53:39 EDT
However, the ALT F2, F3, F4 seems to be only available if one does a 'linux
text' install.

I have successfully installed FC5 on RAID1, LVM as I wanted, but I don't have
any corresponding anaconda.log and syslog.

So, I will do the install over again, but with 'linux text' to get those files
for you.

It is a pretty quick install because I deselected the checkmark on all of the
system types (office, developer, everything, whatever..)

--

Also the sound test asks for the installer to click on the 'Play Test Sound'
button. There is no button of that name, only an arrow (play?) button.
Comment 19 Bob Gustafson 2006-04-30 14:57:39 EDT
Also, before I wipe the files from this FC5 install, the bottom of the
install.log.syslog file says something about Network is unreachable.

This must be at an earlier stage of the install, because the network is
certainly reachable, see screen grab below:

--- This is the bottom of cat /root/install.log.syslog from FC5 install

<86>Apr 30 12:54:39 groupadd[3218]: new group: name=beagleindex, GID=58
<86>Apr 30 12:54:39 useradd[3219]: new user: name=beagleindex, UID=58, GID=58,
home=/var/cache/beagle, shell=/bin/false
<86>Apr 30 13:03:26 useradd[4226]: new group: name=gdm, GID=42
<86>Apr 30 13:03:26 useradd[4226]: new user: name=gdm, UID=42, GID=42,
home=/var/gdm, shell=/sbin/nologin
<86>Apr 30 13:03:26 usermod[4227]: change user `gdm' shell from `/sbin/nologin'
to `/sbin/nologin'
<11>Apr 30 13:04:42 python: failed to set default route: Network is unreachable
[root@hoho2 ~]#  ping 192.168.49.21
PING 192.168.49.21 (192.168.49.21) 56(84) bytes of data.
64 bytes from 192.168.49.21: icmp_seq=1 ttl=64 time=5.14 ms
64 bytes from 192.168.49.21: icmp_seq=2 ttl=64 time=0.304 ms
64 bytes from 192.168.49.21: icmp_seq=3 ttl=64 time=0.345 ms
64 bytes from 192.168.49.21: icmp_seq=4 ttl=64 time=0.389 ms

--- 192.168.49.21 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3012ms
rtt min/avg/max/mdev = 0.304/1.546/5.149/2.080 ms
[root@hoho2 ~]# ping www.google.com
PING www.l.google.com (72.14.203.104) 56(84) bytes of data.
64 bytes from 72.14.203.104: icmp_seq=1 ttl=245 time=13.0 ms
64 bytes from 72.14.203.104: icmp_seq=2 ttl=245 time=12.0 ms
64 bytes from 72.14.203.104: icmp_seq=3 ttl=245 time=11.1 ms

--- www.l.google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 11.137/12.076/13.006/0.763 ms
[root@hoho2 ~]#
Comment 20 Bob Gustafson 2006-04-30 15:22:30 EDT
Well, that's pretty interesting.

If I boot up the machine using Fedora Core FOUR disc 1, going through the
English, English us, to the Disk Setup window:

Both SCSI disks show (sda, sdb), the LVM Volume Group rootvg->root is shown, all
3 RAID Devices are shown /dev/md0, /dev/md1, /dev/md2 and the rootvg is shown on
the Mount Point/RAID/Volume column of /dev/md2, just as it should be..

A difference between this and FC5 is that sda on FC5 seems to be the cdrom drive
(maybe the loop device - neet to go back and look). The first (and only) SCSI
disk in the FC5 install is sdb  - it does not see the other disk, and therefore
cannot start up the RAID devices.

I think I will go forward and install FC4 on this system and then go back and
try to install FC5. Perhaps something will have changed (??).
Comment 21 Bob Gustafson 2006-04-30 15:29:03 EDT
I am using two machines - the target machine, where I inserted a comment just
recently, and this machine where I submitted a comment awhile ago.

When I went back to this machine and did a browser reload, I received the dialog
box saying there was a collision and if I wanted to overwrite, or loose
something. I chose the overwrite, and I see that the text immediately above,
which was submitted at 08:24 today, is submitted again.

What was lost? Who knows? The text above at 14:57 seems to be the last text
submitted from my other (target) machine.

Moving along now..
Comment 22 Bob Gustafson 2006-04-30 15:34:13 EDT
I went back to the Fedora Core FIVE disc 1 and did a 'linux text' install. I
actually did not do the whole install, because all I wanted was the anaconda.log
and syslog for the FC5 install which includes correct information (both SCSI
disks detected at this early stage.

Attachments below are anaconda.log and syslog grabbed after the language and
keyboard questions and before anything is written on the disks.
Comment 23 Bob Gustafson 2006-04-30 15:36:59 EDT
Created attachment 128421 [details]
anaconda.log for correct install run of FC5
Comment 24 Bob Gustafson 2006-04-30 15:38:05 EDT
Created attachment 128422 [details]
syslog from correct install run of FC5
Comment 25 Bob Gustafson 2006-04-30 15:43:21 EDT
I'm done.

I have a good FC5 install and am now downloading updates and then will download
additional software and then will configure some of the things that don't get
configured (vncserver, ..)

I will also write up a suggestion for a better way to install Fedora (minium
software on install, then add additional software from CD's and/or web after the
basic Fedora is installed). This scheme would make it easier for you to debug,
because there is only one minimum system being installed..

See you..
Comment 26 Bob Gustafson 2006-05-02 11:48:30 EDT
Going over some of my own questions:

1) Booting up the installer in 'linux text' mode with the Firewire box turned
off, gives a partition display which DOES NOT include a non scsi sdba.  The two
SCSI disks are now labeled sda and sdb - there is no sdc as in the previous
(early in this note) display

sh-3.1# cat /proc/partitions

major minor  #blocks  name
   7     0     70420 loop0
   8     0  71687372 sda
   8     1    104391 sda1
   8     2   3911827 sda2
   8     3  67665780 sda3
   8    16  71687372 sdb
   8    17    104391 sdb1
   8    18   3911827 sdb2
   8    19  67665780 sdb3

Now, to turn on firewire disk and see if this is the thing that screws up the
subsequent partitioning and RAID LVM in the install process..
Comment 27 Bob Gustafson 2006-05-02 12:44:58 EDT
OK, that was the problem !!

If the firewire disk is turned on and plugged into the machine, then it is
listed in cat /proc/partitions as sda. The two SCSI disks are sdb and sdc.

AND, when I go further into the Fedora Install, the sdc is not seen by the
installer. Booting the FC5 disc 1 and choosing the 'linux text' mode, all three
disks are shown (sda (firew), sdb (SCSI 1), and sdc (SCSI 2) in the ALT F2, cat
/proc/partitions list.

This was the original complaint.

So, the conclusion is that having a firewire disk connected to your machne while
you try to install Fedora Core 5 will screw up the installation process.

It can be fixed by just unplugging the firewire disk.

Done.
Comment 28 Chris Lumens 2007-02-27 10:53:18 EST
Closing as NOTABUG on the basis of comment 27.  Firewire in Linux is
"interesting" anyway, so I can see there being problems here with disks moving
around.  Thanks for doing the research on this to figure out what your problem was.
Comment 29 Bob Gustafson 2007-02-27 11:24:42 EST
The research was mostly frustration with a lucky accident
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=189971#c9

I would say that it is still a bug. The underlying problem (limited media
visibility by anaconda) is still there.

At the minium, to fix bug, please beef up install documentation to say that all
strange media must be disconnected and all RAID arrays must not be in a degraded
state prior to attempting install of Fedora.
Comment 30 Paul W. Frields 2007-05-19 00:38:30 EDT
Fixed in CVS for F7 IG.