Bug 190927

Summary: udev spews multiple errors during boot
Product: [Fedora] Fedora Reporter: David Nielsen <gnomeuser>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: dm, ivg231, john.ellson, laroche, tmokros
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-05-18 11:37:53 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 191248    
Bug Blocks:    

Description David Nielsen 2006-05-06 16:00:42 EDT
Description of problem:
While booting udev spits out the following error

May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid KERNEL operation
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid rule
'/etc/udev/rules.d/10-wacom.rules:3'
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid SUBSYSTEM operation
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid rule
'/etc/udev/rules.d/50-udev.rules:316'
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid SUBSYSTEM operation
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid rule
'/etc/udev/rules.d/50-udev.rules:317'
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid ACTION operation
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid rule
'/etc/udev/rules.d/51-hotplug.rules:4'
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid ACTION operation
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid rule
'/etc/udev/rules.d/51-hotplug.rules:5'
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid KERNEL operation
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid rule
'/etc/udev/rules.d/10-wacom.rules:3'
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid SUBSYSTEM operation
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid rule
'/etc/udev/rules.d/50-udev.rules:316'
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid SUBSYSTEM operation
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid rule
'/etc/udev/rules.d/50-udev.rules:317'
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid ACTION operation
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid rule
'/etc/udev/rules.d/51-hotplug.rules:4'
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid ACTION operation
May  6 14:02:48 localhost udevd[469]: add_to_rules: invalid rule
'/etc/udev/rules.d/51-hotplug.rules:5'

Version-Release number of selected component (if applicable):

udev-091-2
kernel-2.6.16-1.2195_FC6

How reproducible:
100%
Comment 1 John Ellson 2006-05-07 10:06:45 EDT
Also it causes other failures.  loopback fails to start, mouse console services
fail to start, hplip services (hpiod & hpssd) services fail to start.

Reverting to udev-090-1 fixes the problems.

Other error messages are written to the console during startup, but they don't
show up in dmesg or /var/log/messages.

This bug should should be tagged with a higher priority.
Comment 2 Daniel Malmgren 2006-05-08 02:00:35 EDT
(In reply to comment #1)
> Reverting to udev-090-1 fixes the problems.

Where do you download that? It seems to have been removed from all download 
servers...

> This bug should should be tagged with a higher priority.

+1. This one really breaks the entire system...
Comment 3 David Nielsen 2006-05-08 07:27:10 EDT
Priority is overrated, bumping it will not in any way ensure that the bug even
gets more attention - it does not break anything in a data corrupting manner or
cause a noticable crash. I haven't see it "break the entire system".

I'm sure this will be fixed within the next few days, it's a rather obvious bug
(remember it has been weekend while this bug was included, only the fewest
maintainers submit package updates during the weekend).

so please.. settle down people, this is Development - it's supposed to eat a few
babies.
Comment 4 Harald Hoyer 2006-05-10 00:59:56 EDT
fixed 50-udev.rules, 51-udev.rules in rawhide.. waiting for bug #191248
Comment 5 Ryan James 2006-05-15 18:27:59 EDT
udev doesn't seem to be creating /dev/mem on either my laptop or workstation, so
X won't start.  dropping back to udev-90 creates /dev/mem, but causes other
issues (no network).
Comment 6 Harald Hoyer 2006-05-18 10:44:10 EDT
*** Bug 192210 has been marked as a duplicate of this bug. ***
Comment 7 David Nielsen 2006-05-18 10:52:10 EDT
re: #5:
I noticed a lack of working network with this release, however in the logs this
turned out to be a SELinux policy error and "fixfiles relabel" fixed the issue.
Comment 8 Harald Hoyer 2006-05-18 11:36:31 EDT
*** Bug 192210 has been marked as a duplicate of this bug. ***
Comment 9 Harald Hoyer 2006-05-18 11:37:53 EDT
original bug report from comment #1 fixed with udev-092-1

for other udev bugs, please open seperate bugzillas.