Bug 192957

Summary: Xen does not balloon enough when creating an HVM domain
Product: [Fedora] Fedora Reporter: Rik van Riel <riel>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: bstein, katzj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-07-25 23:04:56 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 192956    
Bug Blocks:    

Description Rik van Riel 2006-05-24 10:49:22 EDT
+++ This bug was initially created as a clone of Bug #192956 +++

Description of problem:

(XEN) domain_crash_sync called from shadow32.c:1100
(XEN) Domain 2 (vcpu#0) crashed on cpu#1:
(XEN) ----[ Xen-3.0.2-2    Not tainted ]----
(XEN) CPU:    1
(XEN) EIP:    0008:[<0000ea08>]
(XEN) EFLAGS: 00010412   CONTEXT: hvm
(XEN) eax: 12af7000   ebx: 000f699a   ecx: 000f699a   edx: 12aed99a
(XEN) esi: 0036d53e   edi: 12bed999   ebp: 00067ea8   esp: 00067e9c
(XEN) cr0: 00050033   cr3: 340ee000
(XEN) ds: 0010   es: 0010   fs: 0010   gs: 0010   ss: 0010   cs: 0008

This cryptic message is caused because a memory allocation fails, due to not
enough memory being ballooned out of dom0 at creation time of the guest.

Version-Release number of selected component (if applicable):


Steps to Reproduce:
1. start an HVM domain
2. crash and burn
Comment 1 Rik van Riel 2006-07-25 23:04:56 EDT
This bug appears to be fixed in the current rawide and FC5 kernels.