This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 192956 - Xen does not balloon enough when creating an HVM domain
Xen does not balloon enough when creating an HVM domain
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks: 192957
  Show dependency treegraph
 
Reported: 2006-05-24 10:48 EDT by Rik van Riel
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 23:04:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rik van Riel 2006-05-24 10:48:03 EDT
Description of problem:

(XEN) domain_crash_sync called from shadow32.c:1100
(XEN) Domain 2 (vcpu#0) crashed on cpu#1:
(XEN) ----[ Xen-3.0.2-2    Not tainted ]----
(XEN) CPU:    1
(XEN) EIP:    0008:[<0000ea08>]
(XEN) EFLAGS: 00010412   CONTEXT: hvm
(XEN) eax: 12af7000   ebx: 000f699a   ecx: 000f699a   edx: 12aed99a
(XEN) esi: 0036d53e   edi: 12bed999   ebp: 00067ea8   esp: 00067e9c
(XEN) cr0: 00050033   cr3: 340ee000
(XEN) ds: 0010   es: 0010   fs: 0010   gs: 0010   ss: 0010   cs: 0008

This cryptic message is caused because a memory allocation fails, due to not
enough memory being ballooned out of dom0 at creation time of the guest.

Version-Release number of selected component (if applicable):

xen-3.0.2-0.FC5.1

Steps to Reproduce:
1. start an HVM domain
2. crash and burn
3.
Comment 2 Rik van Riel 2006-07-25 23:04:44 EDT
This bug appears to be fixed in the current rawide and FC5 kernels.

Note You need to log in before you can comment on or make changes to this bug.