Bug 1930724

Summary: CI: Server-Side Apply should work for oauth.openshift.io/v1: has no tokens
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: apiserver-authAssignee: Standa Laznicka <slaznick>
Status: CLOSED ERRATA QA Contact: pmali
Severity: medium Docs Contact:
Priority: medium    
Version: 4.6CC: aos-bugs, mfojtik, mmasters, pmali, scheng, xxia
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-03-25 04:45:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1908217    
Bug Blocks:    

Comment 1 Standa Laznicka 2021-03-01 08:12:49 UTC
*** Bug 1930548 has been marked as a duplicate of this bug. ***

Comment 4 pmali 2021-03-08 04:37:15 UTC
Searched e2e logs for 4.6 for last 120 hours, Saw below errors: Marking as failed

$  w3m -dump -cols 200 'https://search.ci.openshift.org/?search=OAuthClientAuthorization.oauth.openshift.io+%22user%3Asystem%3Aserviceaccount%3A.*+is+invalid%3A+clientName%3A+Internal+error%3A+system%3Aserviceaccount%3A.*+has+no+tokens&maxAge=120h&context=1&type=junit&name=4.6&maxMatches=5&maxBytes=20971520&groupBy=job' | grep 'failures match' | sort
periodic-ci-openshift-release-master-ci-4.6-upgrade-from-stable-4.5-e2e-aws-ovn-upgrade (all) - 50 runs, 98% failed, 4% of failures match = 4% impact
periodic-ci-openshift-release-master-ci-4.6-upgrade-from-stable-4.5-e2e-azure-ovn-upgrade (all) - 20 runs, 100% failed, 5% of failures match = 5% impact
periodic-ci-openshift-release-master-nightly-4.6-e2e-aws (all) - 19 runs, 21% failed, 25% of failures match = 5% impact
periodic-ci-openshift-release-master-nightly-4.6-e2e-gcp (all) - 16 runs, 38% failed, 17% of failures match = 6% impact
periodic-ci-openshift-release-master-nightly-4.6-e2e-vsphere-upi (all) - 25 runs, 88% failed, 14% of failures match = 12% impact
pull-ci-openshift-origin-release-4.6-e2e-gcp (all) - 4 runs, 25% failed, 100% of failures match = 25% impact
pull-ci-openshift-ovn-kubernetes-release-4.6-e2e-vsphere-ovn (all) - 30 runs, 97% failed, 7% of failures match = 7% impact
release-openshift-ocp-installer-e2e-aws-mirrors-4.6 (all) - 3 runs, 100% failed, 33% of failures match = 33% impact
release-openshift-ocp-installer-e2e-gcp-ovn-4.6 (all) - 10 runs, 60% failed, 33% of failures match = 20% imp

Comment 5 Standa Laznicka 2021-03-08 09:11:09 UTC
On the link above I can see that the latest failure was ~3 days ago, which is around the time when the fix merged. No new failures after that but I can see that the sample of the tests is not so great. Moving back to QA to check again since the tests that we can be sure got the fix seem to actually pass.

Comment 9 errata-xmlrpc 2021-03-25 04:45:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.22 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0825