Bug 1930548 - [sig-api-machinery][Feature:ServerSideApply] Server-Side Apply should work for oauth.openshift.io/v1, Resource=oauthclientauthorizations
Summary: [sig-api-machinery][Feature:ServerSideApply] Server-Side Apply should work fo...
Keywords:
Status: CLOSED DUPLICATE of bug 1930724
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Standa Laznicka
QA Contact: pmali
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-19 06:37 UTC by Miciah Dashiel Butler Masters
Modified: 2021-03-01 08:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
[sig-api-machinery][Feature:ServerSideApply] Server-Side Apply should work for oauth.openshift.io/v1, Resource=oauthclientauthorizations
Last Closed: 2021-03-01 08:12:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Miciah Dashiel Butler Masters 2021-02-19 06:37:24 UTC
The "[sig-api-machinery][Feature:ServerSideApply] Server-Side Apply should work for oauth.openshift.io/v1, Resource=oauthclientauthorizations" CI test is failing frequently; see the search results:
https://search.ci.openshift.org/?maxAge=168h&context=1&type=bug%2Bjunit&name=&maxMatches=5&maxBytes=20971520&groupBy=job&search=%5C%5Bsig-api-machinery%5C%5D%5C%5BFeature%3AServerSideApply%5C%5D+Server-Side+Apply+should+work+for+oauth%5C.openshift%5C.io%2Fv1%2C+Resource%3Doauthclientauthorizations

For example, https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/openshift_cluster-version-operator/517/pull-ci-openshift-cluster-version-operator-release-4.6-e2e-agnostic/1362560456950026240 has the following error:

    fail [github.com/openshift/origin/test/extended/apiserver/apply.go:171]: Unexpected error:
        <*errors.StatusError | 0xc000c43220>: {
            ErrStatus: {
                TypeMeta: {Kind: "Status", APIVersion: "v1"},
                ListMeta: {
                    SelfLink: "",
                    ResourceVersion: "",
                    Continue: "",
                    RemainingItemCount: nil,
                },
                Status: "Failure",
                Message: "OAuthClientAuthorization.oauth.openshift.io \"user:system:serviceaccount:e2e-test-server-side-apply-xgrl8:clientg\" is invalid: clientName: Internal error: system:serviceaccount:e2e-test-server-side-apply-xgrl8:clientg has no tokens",
                Reason: "Invalid",
                Details: {
                    Name: "user:system:serviceaccount:e2e-test-server-side-apply-xgrl8:clientg",
                    Group: "oauth.openshift.io",
                    Kind: "OAuthClientAuthorization",
                    UID: "",
                    Causes: [
                        {
                            Type: "InternalError",
                            Message: "Internal error: system:serviceaccount:e2e-test-server-side-apply-xgrl8:clientg has no tokens",
                            Field: "clientName",
                        },
                    ],
                    RetryAfterSeconds: 0,
                },
                Code: 422,
            },
        }
        OAuthClientAuthorization.oauth.openshift.io "user:system:serviceaccount:e2e-test-server-side-apply-xgrl8:clientg" is invalid: clientName: Internal error: system:serviceaccount:e2e-test-server-side-apply-xgrl8:clientg has no tokens
    occurred

This looks like the same failure as bug 1908217, which was fixed in 4.7.0, so perhaps the existing fix needs to be backported.

Comment 1 Standa Laznicka 2021-03-01 08:12:49 UTC

*** This bug has been marked as a duplicate of bug 1930724 ***


Note You need to log in before you can comment on or make changes to this bug.