Bug 1935180

Summary: [4.7z] IGMP/MLD packets being dropped
Product: OpenShift Container Platform Reporter: Tim Rozet <trozet>
Component: NetworkingAssignee: Victor Pickard <vpickard>
Networking sub component: ovn-kubernetes QA Contact: Weibin Liang <weliang>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: anusaxen, dceara, vpickard
Version: 4.7   
Target Milestone: ---   
Target Release: 4.7.z   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: 1935155 Environment:
Last Closed: 2021-04-05 13:55:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1935155    
Bug Blocks:    

Description Tim Rozet 2021-03-04 13:52:33 UTC
+++ This bug was initially created as a clone of Bug #1935155 +++

Description of problem:

Ovn-k8s multicast allow acls should allow IGMP/MLD pkts regardless of source address.

IPv6 MLD packets are being dropped.

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce

There is a detailed slack conversation regarding this issue here:


I have an ipv4 single stack cluster with ovn-kubernetes cni.
I see that after few minutes ~5, the join (igmp) request is expired.
I'm following the steps in the openshift "enable multicast" guide.

If I run

oc exec mlistener -i -t -- \
    socat UDP4-RECVFROM:30102,ip-add-membership=$POD_IP,fork EXEC:hostname

then I run

oc exec msender -i -t -- \
    /bin/bash -c "echo | socat STDIO UDP4-DATAGRAM:,range=$CIDR,ip-multicast-ttl=64"

It works as expected.

But if I run the send request again after ~5 min, it doesn't work. I need the "listener" to re-join the multicast group to make it work again.

Actual results:

Expected results:

Additional info:

Comment 2 Weibin Liang 2021-03-25 16:31:41 UTC
Tested and verified in 4.7.0-0.nightly-2021-03-25-091845

Comment 5 errata-xmlrpc 2021-04-05 13:55:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.7.5 security and bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.