Bug 1935155 - IGMP/MLD packets being dropped
Summary: IGMP/MLD packets being dropped
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.7
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
: 4.8.0
Assignee: Dumitru Ceara
QA Contact: Weibin Liang
Depends On:
Blocks: 1935180
TreeView+ depends on / blocked
Reported: 2021-03-04 13:11 UTC by Victor Pickard
Modified: 2021-07-27 22:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1935180 (view as bug list)
Last Closed: 2021-07-27 22:51:10 UTC
Target Upstream Version:
weliang: needinfo-

Attachments (Terms of Use)

System ID Private Priority Status Summary Last Updated
Github ovn-org ovn-kubernetes pull 2088 0 None open Fix multicast querier. 2021-03-04 13:16:02 UTC
Red Hat Product Errata RHSA-2021:2438 0 None None None 2021-07-27 22:51:41 UTC

Description Victor Pickard 2021-03-04 13:11:26 UTC
Description of problem:

Ovn-k8s multicast allow acls should allow IGMP/MLD pkts regardless of source address.

IPv6 MLD packets are being dropped.

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce

There is a detailed slack conversation regarding this issue here:


I have an ipv4 single stack cluster with ovn-kubernetes cni.
I see that after few minutes ~5, the join (igmp) request is expired.
I'm following the steps in the openshift "enable multicast" guide.

If I run

oc exec mlistener -i -t -- \
    socat UDP4-RECVFROM:30102,ip-add-membership=$POD_IP,fork EXEC:hostname

then I run

oc exec msender -i -t -- \
    /bin/bash -c "echo | socat STDIO UDP4-DATAGRAM:,range=$CIDR,ip-multicast-ttl=64"

It works as expected.

But if I run the send request again after ~5 min, it doesn't work. I need the "listener" to re-join the multicast group to make it work again.

Actual results:

Expected results:

Additional info:

Comment 2 Weibin Liang 2021-03-17 17:10:34 UTC
https://github.com/ovn-org/ovn-kubernetes/pull/2088 is merged in ovn-org:master, but not in openshift:release-4.7

Testing still failed in 4.7.0-0.nightly-2021-03-17-090327

Comment 3 Victor Pickard 2021-03-17 17:16:25 UTC
@weliang This BZ should be verified in 4.8 nightly, right?

There is another BZ, https://bugzilla.redhat.com/show_bug.cgi?id=1935180, for the backport to 4.7.z.

Comment 4 Weibin Liang 2021-03-17 18:26:55 UTC
@vpickard Thanks for infor

Testing passed in 4.8.0-0.nightly-2021-03-17-123640.

Comment 8 errata-xmlrpc 2021-07-27 22:51:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.8.2 bug fix and security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.