Bug 194027

Summary: Review Request: metisse - Experimental X desktop with OpenGL
Product: [Fedora] Fedora Reporter: Christopher Stone <chris.stone>
Component: Package ReviewAssignee: Luya Tshimbalanga <luya_tfz>
Status: CLOSED CANTFIX QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: bdpepple, kwizart
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-01-08 18:43:20 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 201449    

Description Christopher Stone 2006-06-04 23:46:34 EDT
Spec URL: http://tkmame.retrogames.com/fedora-extras/metisse.spec
SRPM URL: http://tkmame.retrogames.com/fedora-extras/metisse-0.4.0-1.src.rpm

Metisse is an experimental X desktop with some OpenGL capacity.  It
consists of a virtual X server called Xwnc, a special version of FVWM,
and a FVWM module FvwmAmetista.

NOTE: This should obsolete bug #177080
Comment 1 Luya Tshimbalanga 2006-06-05 05:50:46 EDT
*** Bug 177080 has been marked as a duplicate of this bug. ***
Comment 2 Luya Tshimbalanga 2006-06-06 17:13:24 EDT
Here is the attempt to build:

$ su -c "yum-builddep rpmbuild/SRPMS/metisse-0.4.0-1.src.rpm"Mot de passe :
Setting up repositories
Traceback (most recent call last):
  File "/usr/bin/yum-builddep", line 97, in ?
  File "/usr/bin/yum-builddep", line 80, in main
    pkg = base.returnPackageByDep(dep)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 1551, in
    raise Errors.YumBaseError, 'No Package found for %s' % depstring
yum.Errors.YumBaseError: No Package found for xorg-x11-devel

it looks like theres is  problem with the condition using Fedora Core 5 as it
will only get "4". I cannot go further because of the reproduced issue using
Fedora Core 5 x86_64. 
Comment 3 Christopher Stone 2006-06-06 17:40:58 EDT
hmm I've never used yum-builddep before.  I'm using %fedora as described here:


This should build fine using mock.  You may want to just try commenting out the
BuildRequires: xorg-x11-devel if you want to use yum-builddep.  Or try building
using mock.  The package review guidelines
http://fedoraproject.org/wiki/Packaging/ReviewGuidelines mention under the
"SHOULD" section that the reviewer should test the package using mock.
Comment 4 Wart 2006-06-06 20:04:31 EDT
It builds fine for me in mock on FC4 and FC5, both i386 and x86_64.  Haven't
tried running it though.

On FC4-x8_64, rpmlint warns:
E: metisse binary-or-shlib-defines-rpath
/usr/libexec/fvwm-insitu/2.5.14/FvwmAmetista ['/usr/lib64']
W: metisse non-standard-dir-in-usr libexec
W: metisse-devel no-documentation
W: metisse-xwnc no-documentation

Tne no documentation warnings might be ok if upstream doesn't provide anything.
I have a vague recollection that FC4-x86_64 sometimes gives erroneous rpath
warnings, but I don't recall where I saw it before.
Comment 5 Christopher Stone 2006-06-06 20:19:43 EDT
Yea, I tried all kinds of things to try to get rid of this error, but could not
figure out how to do it.  That is basically what all the libtool stuff in the
spec file is trying to accomplish.  I'm hoping we can just ignore the rpath
error, I did mentioned it to warren.  If anyone has any idea how to fix the
rpath thing, please let me know!
Comment 6 Wart 2006-06-06 20:36:05 EDT
I tried installing metisse on my FC5-i386 box, and but I get a blank screen
followed by the "short session" warning when I tried to login after selecting it
as the default session in gdm:

"Your session only lasted less than 10 seconds.  If you have not logged out..."
If I view the .xsession-errors details, I see the error:
Invalid geometry 1024X768
...followed by the X usage information, followed by:
Start fvwmi with args -d :0 -w wnc:// -np for FvwmAmetista
[FVWM][main]: <<ERROR>> can't open display
Comment 7 Christopher Stone 2006-06-06 21:08:38 EDT
I admit I didn't even bother trying to test this package, as I am only
interested in the Xwnc part.  The geometry error can be fixed by using a
lower-case X in the /usr/bin/metisse-session file.  I tried testing it out
myself just now and metisse crashes on me after fixing the geometry.

This package may just be a lost cause to try and package.  I may have to abandon
it and just use my original xwnc only package until metisse is more mature in
like twenty years to never.

Please let me know if anyone has any success in getting this to actually work. 
If not, I will just close this bug as WONTFIX and submit an Xwnc only package.
Comment 8 Luya Tshimbalanga 2006-06-07 02:29:37 EDT
I will suggest to contact the developers about these issues as the problem
appears to be upstream. I haven't built metisse yet because of some issue
related to mock 
Comment 9 Christopher Stone 2006-06-07 02:45:09 EDT
This is what I have in my /etc/mock/fedora-5-x86_64-core.cfg file, you could
probably just change x86_64 to i386 if you want to build for that arch.  I'm
surprised they haven't updated these yet.

# repos



Comment 10 Rudolf Kastl 2006-06-14 21:54:19 EDT
i packaged metisse successfully for earlier fedora versions on newrpms... going
to take a look at it, maybe i can help. please dont wontfix this bug yet.
Comment 11 Christopher Stone 2006-06-14 22:32:00 EDT
It's possible it works on i386 in which I can excludearch x86_64 and make an
xwnc only package for x86_64.  We still need someone to test this on an i386
platform.  But please let me know if you find some problem that can be fixed. 
Comment 12 Christopher Stone 2006-06-14 22:58:09 EDT
I've made some minor fixes to the spec file:

Spec URL: http://tkmame.retrogames.com/fedora-extras/metisse.spec
SRPM URL: http://tkmame.retrogames.com/fedora-extras/metisse-0.4.0-2.src.rpm

* Wed Jun 14 2006 Christopher Stone <chris.stone@gmail.com> 0.4.0-2
- Remove %%makeinstall macro
- Fix up libtool usage
- Fix resolution setting in metisse-session file
- Remove pkgconfig from BuildRequires
Comment 13 Luya Tshimbalanga 2006-06-15 04:29:28 EDT
(In reply to comment #9)
> This is what I have in my /etc/mock/fedora-5-x86_64-core.cfg file, you could
> probably just change x86_64 to i386 if you want to build for that arch.  I'm
> surprised they haven't updated these yet.

I have the same configuration and still got the same issue I posted earlier with
mock. For some reason, metisse won't compile as if the condition found on the
spec file will move to '4' by default.
Comment 14 Christopher Stone 2006-09-03 00:29:04 EDT
I'm orphaning nucleo for FC6 and giving up on metisse.  If anyone wants to take
this over be my guest.
Comment 15 Christopher Stone 2007-01-08 18:43:20 EST
I have placed and xwnc package up for review.  xwnc ofcourse is a component of
metisse.  I'm going to go ahead and block this bug against FE-DEADREVIEW

For the xwnc review see bug #221924
Comment 16 Nicolas Chauvet (kwizart) 2007-01-28 22:21:20 EST
I have tryed to made new packages!
 (I didn't know if anyone have made it already...) 
But i thought nucleo has a BR to ffmpeg-devel which isn't avaible in extras? 
(so you don't enabled it i suppose...)

Please do not consider this as a review since it will need packages not provided
in extras reposository... (it is just a handshake!)


Since nucleo do not build on x86_64 i've thought it was never used to build.
Which is untrue, older version seems to build fine on x86_64...
I don't understood metisse was post 0.4.0 release... (this file is a rc4
released in 01/2007!)
Theses packages are marked as orphaned on you fedoraproject wiki pages, i'm
interested in them... Can we work together ?
Comment 17 Christopher Stone 2007-01-28 23:42:06 EST
The nucleo spec file in cvs has patches to make it work on x86_64.

Michel Salim <michel.salim@gmail.com> contacted me a couple days ago also
expressing interest in unorphaning this package.  You should also contact him.
Comment 18 Graham 2007-05-06 05:06:03 EDT
I have a build on my FC6 x86 laptop but it just segfaults when you run it up.

Comment 19 Nicolas Chauvet (kwizart) 2007-05-06 07:07:53 EDT
The mains problems are that it Requires ffmpeg (not in Fedora) and maybe tinyvnc
which cannot compile on x86. Maybe it can be changed into realvnc.

I haven't worked on them since theses version
Some users (and i) report it to work fine with my rpms... (no segfaults).

Comment 20 Christopher Stone 2008-05-24 13:21:30 EDT
I've archived these rpms here incase anyone is interested in the future: