Bug 195858

Summary: Any version fails to build
Product: [Fedora] Fedora Reporter: Paul F. Johnson <paul>
Component: amayaAssignee: Paul F. Johnson <paul>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: extras-qa, lystor, paul
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-10-12 12:35:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 195857, 198247    
Bug Blocks: 195652    
Attachments:
Description Flags
Patch to link against libpng10 rather than libpng none

Description Paul F. Johnson 2006-06-18 21:26:28 UTC
Description of problem:
Amaya (9.5 or 9.51) currently fails to build due to a missing symbol in libpng-12

Version-Release number of selected component (if applicable):
9.5.1 or 9.5
libpng-1.2.10-5

How reproducible:
Always

Additional info:

Missing symbol reported in BZ 195857

Comment 1 Paul Howarth 2006-06-28 15:42:58 UTC
The missing symbol bug needs to be re-reported since Bug #195857 was reassigned
to a different bug following the bugzilla crash.

Comment 2 Paul Howarth 2006-06-29 20:12:31 UTC
Created attachment 131773 [details]
Patch to link against libpng10 rather than libpng

Don't know what I was thinking with Comment #1. Must have been looking at a
different bug.

Anyway, if you can get imlib and libpng10 into FC6 Extras, the attached patch
will allow amaya to build.

Comment 3 Paul Howarth 2006-07-14 17:48:38 UTC
Adding dep on libpng10 review request. With imlib already in Extras, all that's
needed to get amaya going again is libpng10.

Comment 4 Paul F. Johnson 2006-07-14 18:24:46 UTC
I'm unable to get it to build on x86_64 or x86 with libpng10 (I've done a
rebuild on a local box) or libpng proper. I know there is a blocker on x86_64,
but the i386 problem is a stumper

Comment 5 Paul Howarth 2006-07-14 19:35:13 UTC
Not even with the patch from Comment #2? I did test that one in mock before I
attached it, so maybe something has changed in rawhide?

Comment 6 Paul F. Johnson 2006-07-14 22:01:20 UTC
It completely fails to build in either x86 or x86_64 due to BMfile.c having a
problem. This may be a gcc issue though. The source looks okay from here.

Comment 7 Paul F. Johnson 2006-08-20 10:18:48 UTC
*** Bug 203256 has been marked as a duplicate of this bug. ***

Comment 8 Matt Domsch 2006-10-12 12:35:27 UTC
amaya marked as a dead.package 11-Oct-2006. Closing.