Bug 195888

Summary: expat 2.0
Product: [Fedora] Fedora Reporter: Joe Orton <jorton>
Component: expatAssignee: Joe Orton <jorton>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: axel.thimm, bojan, cbalint, dakingun, davidz, denis, eric.moret, gemi, hdegoede, james.antill, jan.kratochvil, jochen, katzj, lpoetter, lxtnow, mattdm, michel.salim, orion, ovasik, packages, paul, pwouters, rjones, robin.norwood, roozbeh, sander, silfreed, thomas
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-08-28 05:17:03 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 251361    
Bug Blocks: 235704    

Description Joe Orton 2006-06-19 06:37:01 EDT
Description of problem:
expat 2.0.0 has been out for six months; it breaks SONAME relative to 1.9.x.  An
upgrade to this might be worthwhile for FC7.
Comment 1 Thorsten Leemhuis 2007-01-28 05:46:51 EST
*** Bug 224178 has been marked as a duplicate of this bug. ***
Comment 2 Joe Orton 2007-02-06 04:40:28 EST
The cost of this upgrade is high (20+ packages depend on libexpat.so.0 in Core
alone; a new compat package would certainly be needed) but the benefit fairly
low; I'm not sure it's actually worth doing this.
Comment 3 Zing 2007-06-18 16:25:14 EDT
Do we have a problem that pyexpat is at 2.0 and apache is linked to 1.95.8 and
with mod_python we could have a clash?  This seems to be documented here as a
real problem:

http://www.dscpl.com.au/wiki/ModPython/Articles/ExpatCausingApacheCrash

, but I don't know for sure.  
Comment 4 Joe Orton 2007-06-18 16:29:33 EDT
If pyexpat is embedding a statically linked copy of expat, that is a bug.

If pyexpat is embedding a statically linked copy of expat and exposing the
symbols to the global symbol namespace as-is, that is a really bad bug.
Comment 5 Jeremy Katz 2007-06-26 19:19:58 EDT
2.0.1 is out now.  Probably worth an upgrade for F8, even though rebuilding 20
packages isn't fun.
Comment 6 Joe Orton 2007-08-08 11:41:32 EDT
The "20" number was pre-Extras-merge.  Post-Merge, the number is 66 :(

Compat package prepared for review here in bug 251361, I'm working through mock
rebuilds of all dependant packages, to see if anything will break.
Comment 7 Joe Orton 2007-08-28 05:17:03 EDT
expat 2.0.1 is now in dist-f8.  You are being CC'ed on this bug if your package
needs to be rebuilt against expat 2.x in Raw Hide.  There is one minor API
change in this release, which maintainers may wish to check for:

        - XML_GetCurrentLineNumber() and  XML_GetCurrentColumnNumber()
          now return unsigned integers.

The list of packages which still need to be rebuilt is here:

http://www.redhat.com/archives/fedora-devel-list/2007-August/msg01939.html

(based on the last Raw Hide push I got - so apologies for any stale data)
Comment 8 Hans de Goede 2007-08-28 10:48:24 EDT
FYI:

acs
gnome-games
paragui[*]
scorched3d
vegastrike
wxGTK[*]

Have been rebuild (in dependency order where aplicable)

Comment 9 Douglas E. Warner 2007-08-28 10:58:39 EDT
The following was rebuilt this morning:

qgis : http://koji.fedoraproject.org/koji/taskinfo?taskID=134051
Comment 10 Denis Leroy 2007-08-28 11:00:51 EDT
k3d is being built right now, though it's taking forever.
Comment 11 Paul Wouters 2007-08-28 12:16:46 EDT
xoo has been rebuild
Comment 12 Richard W.M. Jones 2007-08-28 13:54:46 EDT
ocaml-expat done
(http://koji.fedoraproject.org/koji/buildinfo?buildID=16696)
Comment 13 Martin Bacovsky 2007-08-28 16:11:30 EDT
avahi has been rebuild
Comment 14 Jan Kratochvil 2007-08-28 16:17:06 EDT
gdb has been rebuilt (gdb-6.6-26.fc8).
Comment 15 Bojan Smojver 2007-08-28 17:18:46 EDT
libapreq2 being built: http://koji.fedoraproject.org/koji/taskinfo?taskID=135573
Comment 16 Ondrej Vasik 2007-08-29 04:12:19 EDT
elinks has been rebuilt (elinks-0.11.3-5.fc8)
Comment 17 Andreas Thienemann 2007-08-29 13:57:46 EDT
ser has been rebuilt.
Comment 18 Eric Moret 2009-10-30 04:07:59 EDT
Could you please comment on bug 131990 and let me know if it may be related to this one?
Comment 19 Eric Moret 2009-10-30 04:10:27 EDT
Please read bug 531990 not 131990 as stated in comment 18.