Bug 1960545

Summary: Overly generic CSS rules for dd and dt elements breaks styling elsewhere in console
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Console Kubevirt PluginAssignee: Aviv Turgeman <aturgema>
Status: CLOSED ERRATA QA Contact: Guohua Ouyang <gouyang>
Severity: medium Docs Contact:
Priority: high    
Version: 4.8CC: aos-bugs, gouyang, yzamir
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-06-22 08:29:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1960544    
Bug Blocks:    

Description OpenShift BugZilla Robot 2021-05-14 07:37:11 UTC
+++ This bug was initially created as a clone of Bug #1959550 +++

Created attachment 1782122 [details]
Pod details page without kubevirt plugin

Description of problem:  The rules at https://github.com/openshift/console/blame/master/frontend/packages/kubevirt-plugin/src/components/create-vm-wizard/tabs/review-tab/review-tab.scss#L28-L50 are much too generic in scope and result in layout issues elsewhere in the console when the kubevirt plugin is installed.  These rules need to be scoped to the review tab, ideally with a class on each dd and dt element.


Steps to Reproduce:
1.  With the kubevirt plugin installed, visit a pod details page
2.  Note the space between details dt and dd items is too small

--- Additional comment from rhamilto@redhat.com on 2021-05-11 18:35:14 UTC ---

Created attachment 1782123 [details]
Pod details page with kubevirt plugin installed

Comment 3 Guohua Ouyang 2021-06-17 00:45:44 UTC
verified on 4.6.32

Comment 5 errata-xmlrpc 2021-06-22 08:29:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.35 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2410