Bug 1985876

Summary: Cannot set 0.0.0.0 as gateway
Product: [oVirt] vdsm Reporter: Ales Musil <amusil>
Component: CoreAssignee: Ales Musil <amusil>
Status: CLOSED CURRENTRELEASE QA Contact: Michael Burman <mburman>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.40.80CC: bugs, mburman, mperina
Target Milestone: ovirt-4.4.8Keywords: Automation, Regression, TestBlocker
Target Release: ---Flags: mperina: ovirt-4.4+
pm-rhel: blocker?
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-08-19 06:22:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Network RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1985879    
Bug Blocks:    

Description Ales Musil 2021-07-26 06:59:48 UTC
Description of problem:
Cannot set 0.0.0.0 as network gateway.

Version-Release number of selected component (if applicable):
4.40.80.2

How reproducible:
100%

Steps to Reproduce:
1. Try to set gateway 0.0.0.0 for network


Actual results:
It fails with nmstate verification error

Expected results:
It should pass

Comment 3 Michael Burman 2021-08-02 11:36:18 UTC
 nmstate                                     noarch                   1.0.2-14.el8_4                                    rhel-8.4-nightly-appstream                    42 k


nmstate with the fix available for us in 4.4.8-3 
BZ 1986285 has been verified.

Comment 5 Michael Burman 2021-08-03 06:45:40 UTC
Verified on - rhvm-4.4.8.2-0.11.el8ev.noarch with:

nmstate-1.0.2-14.el8_4.noarch
NetworkManager-1.30.0-10.el8_4.x86_64
vdsm-4.40.80.3-1.el8ev.x86_64

Comment 6 RHEL Program Management 2021-08-09 03:51:59 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 7 Sandro Bonazzola 2021-08-19 06:22:58 UTC
This bugzilla is included in oVirt 4.4.8 release, published on August 19th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.8 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.