Bug 200684

Summary: Samba fileserver files can be seen but have not read
Product: [Fedora] Fedora Reporter: Andreas Thienemann <andreas>
Component: sambaAssignee: Jay Fenlason <fenlason>
Status: CLOSED ERRATA QA Contact: David Lawrence <dkl>
Severity: high Docs Contact:
Priority: medium    
Version: 5CC: andreas, axonrg, cervajs, chkr, jfeeney, jpar, jplans, spambox, tck, zing
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-09-27 18:37:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 200486    
Bug Blocks:    
Description Flags
Patch fixing the linux client issues none

Description Andreas Thienemann 2006-07-30 20:19:14 UTC
+++ This bug was initially created as a clone of Bug #200486 +++
As the problem manifests itself with FC5 as well, this bug tracks FC5 progress.

Problem is the same as with FC4:

A sample share called fsroot is created, exporting the whole filesystem on the
samba server:

   comment = FSroot
   path = /
   valid users = root
   public = no
   writable = yes
   printable = no

A file is created under /tmp:
[root@rtr ~]# echo foo > /tmp/bar

A client mounts that share: 

[root@bofh ~]# mount //rtr/fsroot /mnt/net
[root@bofh ~]# mount | grep cifs
//rtr/fsroot on /mnt/net type cifs (rw,mand)
[root@bofh ~]#

[root@bofh ~]# head /mnt/net/tmp/bar
head: error reading `/mnt/net/tmp/bar': Permission denied

Rolling back to 3.0.23-1.fc5, the head request succeeds:

[root@bofh ~]# head /mnt/net/tmp/bar
[root@bofh ~]#

Comment 1 Axon 2006-08-01 16:01:56 UTC
I'm getting the same issue when I upgraded to samba-3.0.23a on my FC5 install.

Comment 2 cervajs 2006-08-04 08:11:39 UTC
i have this problem too
confirmed on samba-users

Comment 3 Andreas Thienemann 2006-08-04 08:35:33 UTC
Created attachment 133615 [details]
Patch fixing the linux client issues

Comment 4 Axon 2006-08-08 16:02:41 UTC
Sorry if this is the wrong place to post this, but is there a time frame for
when patched binaries for this issue can be published to the repos? This problem
is a show stopper for me.

Comment 5 Mike 2006-08-09 08:04:29 UTC
Upstream released updated version.


Comment 6 Christian Krause 2006-08-15 19:25:19 UTC
I just want to confirm, that samba-3.0.23b solves the problem. I've recompiled
samba-3.0.23a-1.fc5.1.src.rpm with the new released 3.0.23b samba source
(Patch1: samba-3.0.23a-samr_alias.patch must not be applied, because it is
already fixed in 3.0.23b) and it worked without any problems.

I hope a new FC5 package is released soon, because it is a little bit annoying
that it is not possible to mount an smb/cifs share provided by FC5 using an FC5
(cifs only) as client. ;-)

Comment 7 Peter Bieringer 2006-08-26 19:10:51 UTC
Are there any problem why there is still no package at least on updates-testing?

# yum list --enablerepo development --enablerepo updates-testing samba
Installed Packages
samba.i386                               3.0.23a-1.fc5.1        installed
Available Packages
samba.i386                               3.0.23b-2              development

Can't use the one from development without updating glibc, which I didn't want
at the moment.

BTW: the problem only happens on non-zero size files.

# touch /mnt/cifs/test.txt
# cat /mnt/cifs/test.txt
# echo "1" > /mnt/cifs/test.txt
# cat /mnt/cifs/test.txt
cat: /mnt/cifs/test.txt: Permission denied

Comment 8 Mike 2006-09-11 10:50:03 UTC
Another bugfix update was reased by samba team:

Maybe it's time to fix this problem?

Comment 9 Mike 2006-09-27 18:34:22 UTC
fixed by: samba-3.0.23c-1.fc5