Bug 200486 - Samba fileserver files can be seen but have not read
Samba fileserver files can be seen but have not read
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks: 200684
  Show dependency treegraph
 
Reported: 2006-07-27 23:55 EDT by Darren Cook
Modified: 2014-08-31 19:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 15:23:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Cook 2006-07-27 23:55:14 EDT
Description of problem:

Since FC4 server upgraded to samba 3.0.23a (from 3.0.23) my FC4 client can still
connect (with no errors) and do a directory listing of a samba directory, but
cannot open a file (there are no errors opening the file but I get no data).

The FC4 client was still running 3.0.23, so I upgraded to 3.0.23a but problem is
identical (I also tried rebooting client after upgrade).

A windows-XP machine can see the file contents correctly.


Version-Release number of selected component (if applicable):

3.0.23a.


How reproducible:

All files affected.


Steps to Reproduce:

I do the samba mount with this command (it is in rc.d/rc.local):
mount -t cifs -o "guest,uid=darren,gid=darren,dir_mode=0775,file_mode=0664"
//fs/fs /mnt/fs

Then after logging in as darren I do:
  cd /mnt/fs/somewhere
  ls -l

I see files with correct permissions, ownership and dates, e.g:
  -rw-rw-r--  1 darren darren    2826 Jan  9  2005 usb.txt

gedit usb.txt tells me access is denied. oocalc of an xls file tells me data
could not be read.

Curiously, writing still works. E.g. "touch test" works. "vi test" opens it, and
saving works and I see a file of 7 bytes:
  -rw-rw-r--   1 darren darren       7 Jul 28 13:01 test

When I do "vi test" again I see an empty file and "[READ ERRORS]".
 

  
Additional info:

1. Bug 200362 is also a problem with same smbclient version, but unlike there I
have no problems with directory listings. It is only reading file data that fails.

2.Here are is my smb.conf on the server (IP addresses and path obfuscated):

# Samba config file created using SWAT
# from 1.2.3.4
# Date: 2004/12/29 14:29:09

# Global parameters
[global]
        dos charset = 932
        unix charset = SJIS
        workgroup = MYGROUP
        server string = File Server
        security = SHARE
        log file = /var/log/samba/%m.log
        max log size = 50
        unix extensions = No
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        dns proxy = No
        ldap ssl = no
        idmap uid = 16777216-33554431
        idmap gid = 16777216-33554431
        cups options = raw

[homes]
        comment = Home Directories
        read only = No
        browseable = No

[fs]
        comment = all in 1.2.3.* subnet can access
        path = /home/share
        read only = No
        guest ok = Yes
        hosts allow = 1.2.3.

[printer1]
        path = /tmp
        read only = No
        guest ok = Yes
        hosts allow = 1.2.3.
        printable = Yes
Comment 1 Darren Cook 2006-07-28 22:26:12 EDT
I've moved my server back to 3.0.23 rpm packages (for all of samba,
samba-common, samba-client, samba-swat), I've left my client machine at 3.0.23a.
Everything works again. So:
  3.0.23 can read 3.0.23
  3.0.23a can read 3.0.23
  3.0.23 cannot read 3.0.23a
  3.0.23a cannot read 3.0.23a

I.e. it is a server problem not a client problem. This disagrees with Bug 200362
where it sounds like a client problem, but perhaps they are two independent bugs?
Comment 2 Darren Cook 2006-07-31 19:59:15 EDT
It never clicked that CIFS is samba, so I was ignoring them, but these kernel
errors are generated (on the client machine) when trying to access the files:
...
Jul 31 10:30:49 myclient kernel:  CIFS VFS: Send error in read = -13
Jul 31 10:31:13 myclient kernel:  CIFS VFS: Send error in read = -13
Jul 31 10:31:17 myclient kernel:  CIFS VFS: Send error in read = -13
Jul 31 10:31:38 myclient kernel:  CIFS VFS: Send error in read = -13
Jul 31 10:31:38 myclient kernel:  CIFS VFS: Send error in read = -13
...

(I don't see any corresponding kernel error on the server side.)
Comment 3 Steve 2006-08-04 04:23:38 EDT
samba works if you are runnig clients on 3.0.23a and servers on 3.0.23.
Comment 4 Andreas Thienemann 2006-08-04 04:36:20 EDT
This is a confirmed upstream-bug. Patch is uploaded to #200684
Comment 5 Christopher Brown 2006-09-28 15:16:31 EDT
This is now fixed as per latest update. Please close.
Comment 6 Jay Fenlason 2006-09-28 15:23:02 EDT
Closing as per comment #5. 
 
I can't build new packages for FC4 because it's in the hands of Fedora Legacy 
now, but the FC5 .src.rpm will probably recompile on FC4 without changes. 

Note You need to log in before you can comment on or make changes to this bug.