Bug 206492

Summary: Review Request: ssss - Shamir's secret sharing scheme
Product: [Fedora] Fedora Reporter: Paul Wouters <paul>
Component: Package ReviewAssignee: Jochen Schmitt <jochen>
Status: CLOSED DUPLICATE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: tomspur
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-09-16 06:24:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Paul Wouters 2006-09-14 18:04:42 UTC
Spec URL: ftp://ftp.xelerance.com/ssss/ssss.spec
SRPM URL: ftp://ftp.xelerance.com/ssss/ssss-0.5-1.src.rpm
Description: 
ssss is an implementation of Shamir's secret sharing scheme.  ssss does
both: the generation of shares for a known secret and the reconstruction
of a secret using user provided shares.

Comment 1 Jochen Schmitt 2006-09-14 18:13:11 UTC
Good:
+ rpmlint don't complaints source rpm.

Bad:
- Local build complaints:
cc1: error: unrecognized command line option "-fasynchronous-unwind-tables/-O2"
Fehler: Fehler-Status beim Beenden von /var/tmp/rpm-tmp.11940 (%build)

Comment 2 Paul Wouters 2006-09-15 02:28:39 UTC
Thanks for checking the package. It was an odd error on my end. I used:

gcc $RPM_OPT_FLAGS/%{optflags} -lgmp -o ssss-split ssss.c

Of course, I should have used either $RPM_OPT_FLAGS or %{optflags}

Oddly enough, it built fine on my x86_64 with those broken flags. But I fixed it
now:

Spec URL: ftp://ftp.xelerance.com/ssss/ssss.spec
SRPM URL: ftp://ftp.xelerance.com/ssss/ssss-0.5-2.src.rpm


Comment 3 Paul Wouters 2006-09-16 06:24:21 UTC

*** This bug has been marked as a duplicate of 206494 ***

Comment 4 Christoph Wickert 2006-12-02 02:24:18 UTC
Marking as bug #201449

Comment 5 Paul Wouters 2007-01-22 22:01:42 UTC
actually not, it was approved in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=206494

Comment 6 Thomas Spura 2010-11-02 16:46:21 UTC
ssss is in fedora, so don't block FE-DEADREVIEW