Bug 2067218

Summary: [RHEL8][RFE] Support of AMD Rome & Milan
Product: Red Hat Enterprise Linux 8 Reporter: Francois Andrieu <fandrieu>
Component: libpfmAssignee: William Cohen <wcohen>
Status: CLOSED ERRATA QA Contact: Lenka Špačková <lkuprova>
Severity: medium Docs Contact: Petr Hybl <phybl>
Priority: medium    
Version: 8.5CC: alanm, cww, fweimer, jvaldez, mkolar, mpetlan, nbertolus, phybl, toneata, wcohen
Target Milestone: rcKeywords: FutureFeature, HardwareEnablement, Triaged, ZStream
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: libpfm-4.10.1-5.el8 Doc Type: Enhancement
Doc Text:
.`libpfm` now supports AMD Zen 2 and Zen 3 processors With this enhancement, users now can access the AMD Zen 2 and Zen 3 performance monitoring hardware using `libpfm`.
Story Points: ---
Clone Of:
: 2088283 (view as bug list) Environment:
Last Closed: 2022-11-08 09:23:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 2071558, 2088283    
Deadline: 2022-07-04   

Comment 7 William Cohen 2022-03-28 13:56:18 UTC
Looking through the libpfm git commits the following looks like they are ones related the AMD Zen processors.

32af524f03eefac249d51d138b9a3065a1d07960
ddafe9d7c187b48950095c283435f47b59b953e9
9982ae5470c20caa716a243bee6bc98a2fba4bfe
fc49676f3f5315b43ae8016151c3d5ba030567f8
ca5321232c20201b3b91b335a104397c13054c51
e06078dba3b373225c61fe682880f35ee8db9651
42c1857c7694cec1a4750a340381d49dd84ca8ff
c99ed181402b21e74744d5f602aceb6a320c7ded
17e622e9539e1f8faf3c0c27889963a537e95537
5a623727cf7111afd09df2cdb0ff4b294d31efa7
ea9752f3fee76798010093c2f35cbf719980997d
e162519d26d313860a9e69889bcc67406f92edc9
de4beb0da7530bc1dcd2f19582dfeca2ecb1d185
cc4ba27e55440f87359bee5176380db1ba4ef8af
e2afb6186dab2419a4b6f79a6adf7cd9bb0f2340
315941fc05f5a487e4eb5efd36ea10438336944b
c132ab4948a828334a8fef00303a4b47f59bb4d9
06197c0543476d40fad1c94d240e46a5d114f887
9c3e9c025efc06f4ac4422d5e87a05d9776cbb94
7970a2513cc077cc5d76db470d679ff948e3ff55

Comment 8 William Cohen 2022-05-08 16:59:36 UTC
zen2/zen3 support should be in libpfm-4.10.1-5.el8.

Comment 13 William Cohen 2022-05-13 17:48:37 UTC
@mkolar could you check the proposed z-stream rpms in the scratch builds and verify that they fufill comment #11:

7. Prepare a RHEL rpm scratch build and have this change validated on the latest RHEL milestone compose by someone other than the developer. A comment must be added to the Bugzilla indicating the validation is successful and there were no observed regressions.

Comment 14 Michal Kolar 2022-05-16 10:40:06 UTC
Working on it.

Comment 15 Michal Kolar 2022-05-16 16:40:10 UTC
(In reply to William Cohen from comment #13)
@wcohen no regression was observed during testing of the proposed scratch builds.

@fandrieu could you provide an OtherQA flag since the customer is able to help with testing?

Comment 16 William Cohen 2022-05-16 19:29:43 UTC
I reserved a zen3 machine Friday in beaker and tried out the libpfm and papi and compared to the existing rhel8.6 rpms the results were definitely better.

Comment 30 errata-xmlrpc 2022-11-08 09:23:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (papi and libpfm bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:7515