Bug 2071558 - [RFE] Support of PAPI library for AMD Rome & Milan
Summary: [RFE] Support of PAPI library for AMD Rome & Milan
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: papi
Version: 8.5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: William Cohen
QA Contact: Lenka Špačková
Petr Hybl
URL:
Whiteboard:
Depends On: 2067218
Blocks: 2088284
TreeView+ depends on / blocked
 
Reported: 2022-04-04 08:16 UTC by Francois Andrieu
Modified: 2022-11-08 09:52 UTC (History)
11 users (show)

Fixed In Version: papi-5.6.0-16.el8
Doc Type: Enhancement
Doc Text:
.`papi` now supports AMD Zen 2 and Zen 3 processors With this enhancement, users now can access the AMD Zen 2 and Zen 3 performance monitoring hardware using `papi`.
Clone Of:
: 2088284 (view as bug list)
Environment:
Last Closed: 2022-11-08 09:23:07 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-117718 0 None None None 2022-04-04 08:18:35 UTC
Red Hat Product Errata RHBA-2022:7515 0 None None None 2022-11-08 09:23:24 UTC

Comment 4 William Cohen 2022-04-04 15:17:44 UTC
PAPI would need some minor updates in the presets stored in papi_events.csv

Quick looks through looks like following commits are related to AMD ZenX changes papi_events.csv:

20890adcb59a1c1648cb70be65332c03a3781e1a
ae449f73abd0849f05ab3e1f3a64bde0c670c645
ccc22b5dda46fea8933d99950c3e30b5298cdd1d
35f93252a6e222299c03f2c94912334488e76b02
344f6493425d865577508ff32b6f65516b1b4394
4616aa717c5301a9a478876661eb8ac1f18c0333
274219e85ba8adcd2e9c78507adf7edb05b71daa
02f34baafb868d183f21bebfd3c46574847b9929

Comment 5 William Cohen 2022-05-08 17:00:37 UTC
AMD Zen2/3 support should be in papi-5.6.0-16.el8.

Comment 8 William Cohen 2022-05-13 17:48:45 UTC
@mkolar could you check the proposed z-stream rpms in the scratch builds and verify that they fufill comment #6:

7. Prepare a RHEL rpm scratch build and have this change validated on the latest RHEL milestone compose by someone other than the developer. A comment must be added to the Bugzilla indicating the validation is successful and there were no observed regressions.

Comment 9 Michal Kolar 2022-05-16 10:41:22 UTC
Working on it.

Comment 10 Michal Kolar 2022-05-16 16:40:55 UTC
(In reply to William Cohen from comment #8)
@wcohen no regression was observed during testing of the proposed scratch builds.

@fandrieu could you provide an OtherQA flag since the customer is able to help with testing?

Comment 11 William Cohen 2022-05-16 19:29:40 UTC
I reserved a zen3 machine Friday in beaker and tried out the libpfm and papi and compared to the existing rhel8.6 rpms the results were definitely better.

Comment 18 William Cohen 2022-06-16 15:23:36 UTC
@lkuprova, you tested on zen2/3 so we don't need the OtherQA? Is that correct?

Comment 19 Lenka Špačková 2022-06-21 06:11:59 UTC
(In reply to William Cohen from comment #18)
> @lkuprova, you tested on zen2/3 so we don't need the OtherQA? Is
> that correct?

Yes, I tested it on both Zen 2 and Zen 3 systems. I consider OtherQA only a nice-to-have.

Comment 29 errata-xmlrpc 2022-11-08 09:23:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (papi and libpfm bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:7515


Note You need to log in before you can comment on or make changes to this bug.