Bug 2084111

Summary: /usr/lib64/libgnuradio-runtime.so.3.10.1 cannot resolve a symbol in libspdlog
Product: [Fedora] Fedora Reporter: Luca Giuzzi <luca.giuzzi>
Component: gnuradioAssignee: Jaroslav Škarvada <jskarvad>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 36CC: brueggemann, drusek, fabio.pellicano, fedora, francesco.kirico, jskarvad, kgwhitmer, lucilanga, mail, marcus, noesgaard
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: gnuradio-3.10.1.0-2.fc36 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-05-17 01:32:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Luca Giuzzi 2022-05-11 12:40:06 UTC
Description of problem:
 gnuradio is not usable as gnuradio runtime depends on a symbol in libspdlog which is not resolved


Version-Release number of selected component (if applicable):


How reproducible:
Any program linking libgnuradio-runtime is affected.
A minimal example is to run

gnuradio-config-info


Steps to Reproduce:
1. gnuradio-config-info
2.
3.

Actual results:

gnuradio-config-info: symbol lookup error: /lib64/libgnuradio-runtime.so.3.10.1: undefined symbol: _ZN6spdlog5sinks15basic_file_sinkINS_7details10null_mutexEEC1ERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEb



Expected results:

output of gnuradio-config-info


Additional info:

Comment 1 Daniel Rusek 2022-05-11 19:56:47 UTC
Still the same issue on Fedora 36 with gnuradio-3.10.1.0-1.fc36.x86_64. GNU Radio does not work at all because of this issue and software that depends on GNU Radio (like Gqrx) also crashes with:

symbol lookup error: /lib64/libgnuradio-runtime.so.3.10.1: undefined symbol: _ZN6spdlog5sinks15basic_file_sinkINS_7details10null_mutexEEC1ERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEb

Comment 2 Jaroslav Škarvada 2022-05-13 12:11:04 UTC
This was probably caused by update of the spdlog during the f36 freeze. I am working on the fix, probably gnuradio rebuild should be enough.

Comment 3 Jaroslav Škarvada 2022-05-13 13:27:50 UTC
*** Bug 2084258 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2022-05-13 13:36:04 UTC
FEDORA-2022-457ac89130 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-457ac89130

Comment 5 Fedora Update System 2022-05-14 02:15:15 UTC
FEDORA-2022-457ac89130 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-457ac89130`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-457ac89130

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Luca Giuzzi 2022-05-14 10:17:56 UTC
I can confirm that the updated package works (both with gnuradio and when linking with external programs e.g. gqrx)

Thanks

Comment 7 Jaroslav Škarvada 2022-05-16 09:07:06 UTC
*** Bug 2086338 has been marked as a duplicate of this bug. ***

Comment 8 Jaroslav Škarvada 2022-05-16 09:08:45 UTC
*** Bug 2085679 has been marked as a duplicate of this bug. ***

Comment 9 Francesco Chirico 2022-05-16 12:43:02 UTC
I can confirm that the updated package solves the problem.

Thanks.

Comment 10 Fedora Update System 2022-05-17 01:32:19 UTC
FEDORA-2022-457ac89130 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Jaroslav Škarvada 2022-05-19 09:53:53 UTC
*** Bug 2087148 has been marked as a duplicate of this bug. ***