Bug 2106277 (CVE-2022-35653, MSA-22-0019)

Summary: CVE-2022-35653 moodle: LTI module reflected XSS risk - affecting unauthenticated users only
Product: [Other] Security Response Reporter: TEJ RATHI <trathi>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED UPSTREAM QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: gwync, igor.raits, security-response-team, sergio
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: moodle 4.0.2, moodle 3.11.8, moodle 3.9.15 Doc Type: If docs needed, set a value
Doc Text:
A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-08-30 07:32:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2108046, 2108045    
Bug Blocks: 2106283, 2110418    

Description TEJ RATHI 2022-07-12 09:23:54 UTC
A minor reflected XSS risk was identified in the LTI module. This did not impact authenticated users.

Versions affected: 4.0 to 4.0.1, 3.11 to 3.11.7, 3.9 to 3.9.14 and earlier unsupported versions
Versions fixed: 4.0.2, 3.11.8 and 3.9.15

Comment 3 TEJ RATHI 2022-07-18 10:55:01 UTC
Created moodle tracking bugs for this issue:

Affects: epel-all [bug 2108046]
Affects: fedora-all [bug 2108045]

Comment 4 Product Security DevOps Team 2022-08-30 07:32:57 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.