Bug 2109837

Summary: mac nfs 4.0 client is not able to create files on nfs share
Product: [Fedora] Fedora Reporter: Igor Mammedov <imammedo>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 36CC: acaringi, adscvr, airlied, alciregi, bskeggs, hdegoede, hpa, jarodwilson, jglisse, jlayton, jonathan, josef, kernel-maint, lgoncalv, linville, masami256, mchehab, ptalbert, steved
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: kernel-5.18.13-200.fc36 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-07-23 02:00:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Igor Mammedov 2022-07-22 09:40:39 UTC
1. Please describe the problem:

Since 5.18 kernels, MacOs client is not able to create file on NFS 4.0 share

2. What is the Version-Release number of the kernel:

kernel-5.18.10-200

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear? 

it worked with 5.17 kernels

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

  1. configure NFS server on Fedora (enable v4.0 support)
  2. mount share from MacOS client share nfs 4.0
  3. try to copy new file from Mac to mounted nfs server share

5. Fixed upstream by:
  commit 5b2f3e0777da2a5dd62824bbe2fdab1d12caaf8f
  NFSD: Decode NFSv4 birth time attribute

Comment 1 Fedora Update System 2022-07-22 20:55:31 UTC
FEDORA-2022-311e6b1153 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-311e6b1153

Comment 2 Fedora Update System 2022-07-23 02:00:16 UTC
FEDORA-2022-311e6b1153 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.