Bug 211745

Summary: xend does not start on x86_64
Product: [Fedora] Fedora Reporter: Ben <bench>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED ERRATA QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: 5CC: bstein, cpaul, katzj, russell, ssnodgra
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-11-04 14:18:26 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ben 2006-10-21 13:30:12 EDT
Description of problem:

This is a similiar problem to bug 208529, but with a different stack trace, so,
here's a different bug report.

Version-Release number of selected component (if applicable):

2.6.18-1.2200.fc5xen0
libvirt-0.1.7-2.FC5
libvirt-devel-0.1.7-2.FC5
xen-3.0.2-5.fc5

How reproducible:

Always.

Steps to Reproduce:

1. service start xend
2. Observe the following added to xend.log:

[2006-10-21 09:37:24 xend 2674] INFO (SrvDaemon:283) Xend Daemon started
[2006-10-21 09:37:24 xend 2674] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-10-21 09:37:24 xend 2674] ERROR (SrvDaemon:297) Exception starting xend
((111, 'Connection refused'))
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDaemon.py", line
291, in run
    servers = SrvServer.create()
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvServer.py", line
108, in create
    root.putChild('xend', SrvRoot())
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvRoot.py", line 40,
in __init__
    self.get(name)
  File "/usr/lib64/python2.4/site-packages/xen/web/SrvDir.py", line 82, in get
    val = val.getobj()
  File "/usr/lib64/python2.4/site-packages/xen/web/SrvDir.py", line 52, in getobj
    self.obj = klassobj()
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDomainDir.py",
line 39, in __init__
    self.xd = XendDomain.instance()
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 636, in
instance
    inst.init()
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 71, in init
    xstransact.Mkdir(VMROOT)
  File "/usr/lib64/python2.4/site-packages/xen/xend/xenstore/xstransact.py",
line 345, in Mkdir
    complete(path, lambda t: t.mkdir(*args))
  File "/usr/lib64/python2.4/site-packages/xen/xend/xenstore/xstransact.py",
line 351, in complete
    t = xstransact(path)
  File "/usr/lib64/python2.4/site-packages/xen/xend/xenstore/xstransact.py",
line 20, in __init__
    self.transaction = xshandle().transaction_start()
  File "/usr/lib64/python2.4/site-packages/xen/xend/xenstore/xsutil.py", line
18, in xshandle
    xs_handle = xen.lowlevel.xs.xs()
Error: (111, 'Connection refused')


Additional info:

Interestingly (?) my normal xend processes remain running, even if xend doesn't
seem to be working:

root      2761  0.0  0.0 105000  5908 ?        S    09:45   0:00 python
/usr/sbin/xend start
root      2762  0.5  0.0 115240  6748 ?        Sl   09:45   0:00 python
/usr/sbin/xend start
Comment 1 Guillaume Bougard 2006-10-21 19:00:13 EDT
Hi,

exactly the same symptom here.

Also the xend python script can't start xenstored thread as expected.

If you try to start 'xenstored' manually, you will obtain:
ERROR: Could not open event channel interface (19 = No such device)
FATAL: Failed to open evtchn device: No such device

If you "strace" xenstored, it seems the device '/dev/xen/evtchn' is not
responding as a device. This explains the error 'No such device'. Is there a
missing driver ?
Comment 2 Guillaume Bougard 2006-10-24 06:26:32 EDT
Hi,

I suspected a problem with the changeset applied as the message says something
like "Xend changeset: unavailable" and if you check the sources from the
"src.rpm", the linux-2.6-xen.patch, you find line 5-6:
 * xen-3.0.3-testing /mnt/ro/repos/hg/xen-3.0.3-testing
changeset:   11740:64b3e8596dc9

Also the kernel-2.6.spec talks about the 11540 changeset of Xen.

So I check the CVS, get the v1.69 of the same patch from the "FC-6" folder, just
adapt it to make the patch working (3 or 4 lines in not xen files). I choose
this one as the Changelog for that version talks about:
 * xen-unstable changeset:   11540:9837ff37e354

Then I recompiled the package installed it and then Xend is starting as expected.

So for me, it's just a mistake on the Xen patch. And it needs a CVS update from
the maintener.

Hope this fix most problems with Xen on FC5.
Comment 3 Russell McOrmond 2006-10-31 10:57:20 EST
I would like to confirm this bug (same versions of kernel-xen,xen,libvirt* as
mentioned above), although I didn't try the patch suggested by Guillaume. 
Contrary to the title of this bug the problem exists on Athlon as well.  I don't
want to bring down my other Xen boxes to test if it fails on other architectures
as well.

I backed out of the changes in order to start the xenU's.  
Comment 4 Daniel Berrange 2006-11-02 16:23:21 EST
Please test the updated Xen 3.0.3-1.fc5 available in updates-testing.

http://www.redhat.com/archives/fedora-test-list/2006-October/msg01060.html
Comment 5 Fedora Update System 2006-11-03 11:30:53 EST
The xen-3.0.3-l.fc5 errata fixes the issues observed in this bug.
Comment 6 Ben 2006-11-04 12:57:12 EST
Works for me. Thanks!