Bug 208529 - xend does not start on x86_64
xend does not start on x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-29 03:49 EDT by Emmanuel Galanos
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-04 14:18:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Galanos 2006-09-29 03:49:20 EDT
Description of problem:

xend does not start and gives an exception as described in bug 199944.

Version-Release number of selected component (if applicable):

xen-3.0.2-3.FC5
kernel-xen-2.6.18-1.2189.fc5

How reproducible:

100%


Steps to Reproduce:
1. service xend start
  
Actual results:

Failed.

Expected results:

Work.

Additional info:

Python exception in /var/log/xend.log:

[2006-09-29 17:34:43 xend] ERROR (SrvDaemon:297) Exception starting xend ((38,
'Function not implemented'))
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDaemon.py", line
291, in run
    servers = SrvServer.create()
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvServer.py", line
108, in create
    root.putChild('xend', SrvRoot())
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvRoot.py", line 40,
in __init__
    self.get(name)
  File "/usr/lib64/python2.4/site-packages/xen/web/SrvDir.py", line 82, in get
    val = val.getobj()
  File "/usr/lib64/python2.4/site-packages/xen/web/SrvDir.py", line 52, in getobj
    self.obj = klassobj()
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDomainDir.py",
line 39, in __init__
    self.xd = XendDomain.instance()
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 609, in
instance
    inst.init()
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 76, in
init
    self._add_domain(
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 139, in
xen_domains
    domlist = xc.domain_getinfo()
Error: (38, 'Function not implemented')
[2006-09-29 17:34:43 xend] INFO (SrvDaemon:183) Xend exited with status 1.
Comment 1 Daniel Berrange 2006-09-29 18:25:34 EDT
From the looks of this trace, a 'kernel-xen' RPM with the new Xen 3.0.3 
hypercall ABI was pushed to updates-testing, without the corresponding update to
'xen' userspace RPM to make the tools work with this new ABI. Recommend
re-booting to an  older kernel-xen until we can get a new 'xen' RPM pushed to
updates-testing.
Comment 2 Chris Langlands 2006-09-29 20:44:11 EDT
No new xen package to go with the 2189 kernel was pushed to updates-testing.  We
thought that this might be the case, and raised the question over at bug 199944
 but were told to open a new bug.

The only xen package is the one from 24-Jun-2006.

# yum --enablerepo=updates-testing list  xen
xen.x86_64          3.0.2-3.FC5            installed
Comment 3 Chris Langlands 2006-10-03 10:32:14 EDT
Is there an ETA on the new xen userspace RPM?
Comment 4 TGS 2006-10-17 01:15:21 EDT
Same problem here - any news?
Comment 5 Thomas von Steiger 2006-10-18 05:16:51 EDT
I have the same problem on i386 or ia32.
Comment 6 Ben 2006-10-21 13:32:03 EDT
FWIW, I have a similar problem but with a different stack trace, so I opened bug
211745.
Comment 7 Steve Snodgrass 2006-10-21 16:53:00 EDT
I'm having similar problems on i686 running the following packages:

kernel-xen0-2.6.18-1.2200.fc5
xen-3.0.2-5.fc5
libvirt-0.1.7-2.FC5

Here's xend.log:

[2006-10-21 16:49:51 xend 2062] INFO (SrvDaemon:283) Xend Daemon started
[2006-10-21 16:49:51 xend 2062] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-10-21 16:49:51 xend 2062] ERROR (SrvDaemon:297) Exception starting xend
((111, 'Connection refused'))
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDaemon.py", line
291, in run
    servers = SrvServer.create()
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvServer.py", line
108, in create
    root.putChild('xend', SrvRoot())
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvRoot.py", line 40,
in __init__
    self.get(name)
  File "/usr/lib/python2.4/site-packages/xen/web/SrvDir.py", line 82, in get
    val = val.getobj()
  File "/usr/lib/python2.4/site-packages/xen/web/SrvDir.py", line 52, in getobj
    self.obj = klassobj()
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDomainDir.py", line
39, in __init__
    self.xd = XendDomain.instance()
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomain.py", line 636, in
instance
    inst.init()
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomain.py", line 71, in init
    xstransact.Mkdir(VMROOT)
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xstransact.py", line
345, in Mkdir
    complete(path, lambda t: t.mkdir(*args))
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xstransact.py", line
351, in complete
    t = xstransact(path)
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xstransact.py", line
20, in __init__
    self.transaction = xshandle().transaction_start()
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xsutil.py", line 18,
in xshandle
    xs_handle = xen.lowlevel.xs.xs()
Error: (111, 'Connection refused')
Comment 8 Guillaume Bougard 2006-10-24 06:30:06 EDT
I just added a comment on
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=211745 that should explains
this bug and maybe others.
Comment 9 Daniel Berrange 2006-11-02 16:23:53 EST
Please test the updated Xen 3.0.3-1.fc5 available in updates-testing.

http://www.redhat.com/archives/fedora-test-list/2006-October/msg01060.html
Comment 10 Fedora Update System 2006-11-03 11:29:51 EST
The xen-3.0.3-l.fc5 errata fixes the issues observed in this bug.
Comment 11 Ben 2006-11-04 12:55:59 EST
yep, works for me. Thanks!

Note You need to log in before you can comment on or make changes to this bug.