Bug 212091

Summary: cpuspeed/cpufreq scaling does not work in 2.6.18-1.2798.fc6
Product: [Fedora] Fedora Reporter: Gregory Gulik <greg>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: 6CC: axelgenus, pfrields, redhat, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-10-28 02:01:17 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Gregory Gulik 2006-10-24 19:24:09 EDT
Description of problem:

CPU frequency scaling does not work in FC6 kernel version 2.6.18-1.2798.fc6
It would appear the acpi-cpufreq.ko file is missing.

Version-Release number of selected component (if applicable):

kernel-2.6.18-1.2798.fc6

How reproducible:

Always

Steps to Reproduce:
1. Boot
2. Start cpuspeed
3. Have a slow system.
  
Actual results:

[root@compaqr3000z ~]# service cpuspeed start
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device


Expected results:

cpuspeed should have started.


Additional info:

CPU frequency scaling worked just fine in FC5.

CPU info is:
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 8
model name      : AMD Athlon(tm) XP Processor 3000+
stepping        : 2
cpu MHz         : 797.944
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 clflush mmx fxsr sse sse2 syscall nx mmxext 3dnowext 3dnow up ts fid vid ttp
bogomips        : 1597.23
Comment 1 Jens Lautenbacher 2006-10-24 21:26:15 EDT
the acpi-cpufreq is there, it seems the relevant stuff in
/sys/devices/system/cpu/cpu0/ is missing (no cpufreq there).

Anyhow, same problem here (and it also worked in fc5):

By the way, I think severity "normal" is not enough here...

[~] $ cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 1.60GHz
stepping        : 8
cpu MHz         : 1596.100
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
clflush dts acpi mmx fxsr sse sse2 ss tm pbe up est tm2
bogomips        : 3195.34

Comment 2 Brice DEKANY 2006-10-25 04:36:31 EDT
Hi everyone,

Same problem here. as Jens says, it was working with FC5-devel

[~]$ cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 1.80GHz
stepping        : 6
cpu MHz         : 1798.512
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8 mtrr pge mca cmov pat clflush
dts acpi mmx fxsr sse sse2 ss tm pbe up est tm2
bogomips        : 3599.49
Comment 3 Brice DEKANY 2006-10-25 08:43:49 EDT
I have read a bunch of tickets about cpuspeed troubles.
Comment 4 Brice DEKANY 2006-10-25 08:45:54 EDT
I have read a bunch of tickets about cpuspeed troubles.
The problem is that the feature ISN'T built-in (or module)

cat /boot/config-2.6.18-1.2798.fc6

#
# CPUFreq processor drivers
#
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_POWERNOW_K6=m
# CONFIG_X86_POWERNOW_K7 is not set
# CONFIG_X86_POWERNOW_K8 is not set
# CONFIG_X86_GX_SUSPMOD is not set
# CONFIG_X86_SPEEDSTEP_CENTRINO is not set
# CONFIG_X86_SPEEDSTEP_ICH is not set
# CONFIG_X86_SPEEDSTEP_SMI is not set
# CONFIG_X86_P4_CLOCKMOD is not set
# CONFIG_X86_CPUFREQ_NFORCE2 is not set
CONFIG_X86_LONGRUN=y
# CONFIG_X86_LONGHAUL is not set
Comment 5 Sergio Monteiro Basto 2006-10-25 14:10:57 EDT
yes, in cat /boot/config-2.6.18-1.2200.fc5 

#
# CPUFreq processor drivers
#
CONFIG_X86_ACPI_CPUFREQ=m
# CONFIG_X86_POWERNOW_K6 is not set
CONFIG_X86_POWERNOW_K7=y
CONFIG_X86_POWERNOW_K7_ACPI=y
CONFIG_X86_POWERNOW_K8=y
CONFIG_X86_POWERNOW_K8_ACPI=y
# CONFIG_X86_GX_SUSPMOD is not set
CONFIG_X86_SPEEDSTEP_CENTRINO=y
CONFIG_X86_SPEEDSTEP_CENTRINO_ACPI=y
CONFIG_X86_SPEEDSTEP_CENTRINO_TABLE=y
CONFIG_X86_SPEEDSTEP_ICH=y
CONFIG_X86_SPEEDSTEP_SMI=y
CONFIG_X86_P4_CLOCKMOD=m
# CONFIG_X86_CPUFREQ_NFORCE2 is not set
CONFIG_X86_LONGRUN=y
# CONFIG_X86_LONGHAUL is not set
Comment 6 Gregory Gulik 2006-10-25 14:58:37 EDT
Ok, I don't get it.  I was doing a bunch of other things to the machine since
installing FC6 on it yesterday and after a reboot a little while ago I was
surprised to discover that frequency scaling now works properly on the Compaq
R3000Z AMD based notebook I originally reported this problem on.

Any idea what I did?

I did install the kernel-devel package, not sure if that did anything.
Comment 7 Richard Körber 2006-10-25 18:42:01 EDT
There are two kernel packages in FC6: kernel-2.6.18-1.2798.fc6.i586.rpm and
kernel-2.6.18-1.2798.fc6.i686.rpm. It seems like the i586 kernel is always
installed, even on i686 machines. The feature isn't built in the i586 kernel,
but in the i686 kernel.

Cpuspeed was working fine for me after bravely executing these lines and rebooting:

rpm -e --nodeps kernel
rpm -i kernel-2.6.18-1.2798.fc6.i686.rpm
Comment 8 Gregory Gulik 2006-10-25 22:56:18 EDT
Installing the i686 version of the kernel was the thing that apparently fixed
frequency scaling on my AMD laptop.

However I just installed FC6 on a Toshiba 1115-S103 notebook.  I did the same
trick of updating the kernel to the i686 version yet frequency scaling doesn't work:

[root@toshiba1115 greg]# service cpuspeed restart
cat: /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver: No such file or directory
WARNING: Error inserting freq_table
(/lib/modules/2.6.18-1.2798.fc6/kernel/drivers/cpufreq/freq_table.ko): Operation
not permitted
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device

Processor info on this particular machine:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Mobile Intel(R) Celeron(R) CPU 1.50GHz
stepping        : 4
cpu MHz         : 1495.636
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36
clflush dts acpi mmx fxsr sse sse2 ss ht tm up
bogomips        : 2994.73
Comment 9 Ken Dreyer 2006-10-26 02:42:16 EDT
I am experiencing the same problems with cpuspeed.

> uname -a
Linux kappa 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:54:20 EDT 2006 i686 i686 i386
GNU/Linux

> service cpuspeed start
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device

> cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 1.80GHz
stepping        : 6
cpu MHz         : 1794.242
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8 mtrr pge mca cmov pat clflush
dts acpi mmx fxsr sse sse2 ss tm pbe up est tm2
bogomips        : 3590.86
Comment 10 Brice DEKANY 2006-10-26 06:55:21 EDT
(In reply to comment #7)
> There are two kernel packages in FC6: kernel-2.6.18-1.2798.fc6.i586.rpm and
> kernel-2.6.18-1.2798.fc6.i686.rpm. It seems like the i586 kernel is always
> installed, even on i686 machines. The feature isn't built in the i586 kernel,
> but in the i686 kernel.
> 
> Cpuspeed was working fine for me after bravely executing these lines and
rebooting:
> 
> rpm -e --nodeps kernel
> rpm -i kernel-2.6.18-1.2798.fc6.i686.rpm

Ok, it works for me.
Thanks

ftp://fr2.rpmfind.net/linux/fedora/core/6/i386/os/Fedora/RPMS/kernel-2.6.18-1.2798.fc6.i686.rpm
Comment 11 Calorì Alessandro 2006-10-26 12:49:30 EDT
Same problem here! I have a HP Compaq nx7400 with an Intel Centrino Core Duo...
It is possible to compile only the module "centrino-speedstep"? It's the only
thing I need and I'd like to avoid to recompile my kernel because (I hope) this
problem is going to be solved by a kernel update in the near future...
Comment 12 Jens Lautenbacher 2006-10-27 06:57:10 EDT
no need to recompile. install the right kernel (i686 instead of i586) as
described in the comments above
Comment 13 Dave Jones 2006-10-28 01:14:29 EDT
*** Bug 212476 has been marked as a duplicate of this bug. ***
Comment 14 Dave Jones 2006-10-28 02:01:17 EDT
There may be several issues here, but a number of them are a side effect of
211941. Replacing the i586 with the i686 kernel should get things working for a
bunch of you.

If there are any leftovers where it still doesn't work, that'll be a real driver
bug. Please open a separate new bug for those as this one is already quite
overloaded with a number of different problems.



*** This bug has been marked as a duplicate of 211941 ***
Comment 15 Valent Turkovic 2006-10-28 08:19:54 EDT
(In reply to comment #7)
> 
> rpm -e --nodeps kernel
> rpm -i kernel-2.6.18-1.2798.fc6.i686.rpm

I tried this and it left me with non booting system!!!
sort of :) It booted into windows (it is a work machine so I HAVE to have Win).
Grub config was erased! So I had to rescue boot from fedora dvd to repair it by 
hand.

Be careful when trying this hack, make grub config backup first "cp /boot/grub/
menu.lst /boot/grub/menu.lst.bkp" and after installing new kernel check that it 
isn't reased as mine.

valent.turkovic@gmail.com
Comment 16 Valent Turkovic 2006-10-28 09:01:24 EDT
Smarter thing is to go to fedora dvd, get the i686 kernel package and do this:
rpm -Uvh --force kernel-2.6.18-1.2798.fc6.i686.rpm
Comment 17 Valent Turkovic 2006-11-09 07:34:39 EST
I found a solution, you need to start Fedora Core 6 install with this command:

linux i686

this instructs installer to use i686 kernel.
Comment 18 Trevin Beattie 2006-11-21 23:13:08 EST
Not sure if you all have already checked this, but on my system AMD PowerNow
support has to be enabled in the BIOS as well as the kernel in order for cpufreq
to work.
Comment 19 Calorì Alessandro 2006-11-22 03:10:11 EST
I already had the i686 kernel but cpuspeed didn't work. This problem is not 
related to drivers because it used to work with other distros (with same kernel 
version)...