Bug 213150

Summary: No kernel to boot after Virtualization is uninstalled
Product: [Fedora] Fedora Reporter: Chester Cheng <ccheng>
Component: xenAssignee: Jeremy Katz <katzj>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: high    
Version: 6CC: amk, katzj, r.landmann, xen-maint
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-30 17:35:54 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Chester Cheng 2006-10-30 18:15:31 EST
Description of problem:


Version-Release number of selected component (if applicable):
FC6

How reproducible:
Easy to reporduce.

Steps to Reproduce:
1. Start a fresh installation of FC6 with "Virtualization" installed.
2. Uninstall "Virtualization" after FC6 is installed.
3. Kernel (with Xen support) is uninstalled, too, which leaves no kernel to boot up.
  
Actual results:
FC6 cannot boot.

Expected results:
FC6 can boot.

Additional info:
Comment 1 Jeremy Katz 2006-10-30 18:18:40 EST
Fun :-)

Would it help if you got a warning saying that you're about to remove required
bits from the system?
Comment 2 Andreas M. Kirchwitz 2006-11-01 19:28:01 EST
Like me, quite a lot people will select everything during package
selection (including Virtualization support), but they don't expect
that Xen is running immediateley after installation and that there
is no alternative kernel installed in case they run into problems
or if they remove Virtualization support.

On the other hand, it's funny to see how good Xen works that a lot
of people maybe never notice that they're now running under Xen.
(I noticed the Xen kernel only because the complex Xen networking
stuff broke my DHCP/IPv6 setup - could be related to bug #213015).

But to get back to the original issue:

If somebody decides to switch back from Xen to old-school kernel,
he will probably run "pirut" and deselect Virtualization support.
That should leave his system in the same state as if he didn't
select Virtualization support during initial installation.

A warning would be nice, but it might not help much.
What is the user expected to do? Run "yum install kernel" manually?
Maybe it might be a good idea to always install an old-school kernel
as a fall-back. Then no matter whether Virtualization is installed
or removed - there's always a regular kernel to boot from.

Sorry if this is a stupid proposal... I'm just in that
situation right now and don't want to screw up the system. ;-)
Comment 3 Chester Cheng 2006-11-01 20:06:40 EST
I think it's a brilliant idea to install 2 kernels (Xen and normal) and make the
Xen kernel as the default one.
Comment 4 Jeremy Katz 2006-11-03 14:21:59 EST
This then means that for the people where things work they're left downloading
twice as many kernels, using twice as much disk space and leading to a less
intuitive interface (the difference between the regular and Xen kernels in the
grub menu is quite subtle).  There's very good reason why we only install one
kernel now.
Comment 5 PC Klopp 2006-12-10 00:51:40 EST
In my opinion, the Xen kernel should be the default and only kernel installed. 
That way, you would be able to add or remove guest systems without harming the
integrity or stability of the host system.  Less complexity is better than more
complexity...... Pete
Comment 6 Jeremy Katz 2007-04-30 17:35:54 EDT
You'll get a warning that your system will be left unbootable now if you remove
kernel-xen with pirut, so closing this out