Bug 213015 - broken xen networking
broken xen networking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Herbert Xu
Brian Brock
:
: 220454 (view as bug list)
Depends On:
Blocks: 204534
  Show dependency treegraph
 
Reported: 2006-10-30 11:07 EST by deneault
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 23:46:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested information about problem (48.77 KB, application/octet-stream)
2006-10-31 12:19 EST, deneault
no flags Details
ifconfig -a (4.36 KB, text/plain)
2006-11-02 06:25 EST, Andreas M. Kirchwitz
no flags Details
route -n (IPv4) (333 bytes, text/plain)
2006-11-02 06:25 EST, Andreas M. Kirchwitz
no flags Details
route -A inet6 -n (IPv6) (2.54 KB, text/plain)
2006-11-02 06:27 EST, Andreas M. Kirchwitz
no flags Details
sysctl -a (23.16 KB, text/plain)
2006-11-02 06:28 EST, Andreas M. Kirchwitz
no flags Details
[BNX2]: Fix Xen problem. (77.35 KB, patch)
2006-12-21 22:52 EST, Herbert Xu
no flags Details | Diff

  None (edit)
Description deneault 2006-10-30 11:07:31 EST
Description of problem:

When xend, starts my eth0 interface becomes inoperable.  When booting with a
non-xen enabled kernel, or a xen-enabled kernel with xend disabled, my eth0
starts and DHCPs without incident.  As soon as Xend is started, the bridges are
created, and my eth0 stops functioning.

Version-Release number of selected component (if applicable):

kernel-xen-2.6.18-1.2798.fc6 x86_64
xen-3.0.3-0.1.rc3

How reproducible:

Every time.

Steps to Reproduce:
1.Boot a xen-enabled kernel with xend running
2.try to use your network connection
  
Actual results:

Cannot connect anywhere

Expected results:

To be able to go somewhere

Additional info:
This is a Dell Poweredge 1950.
Comment 1 deneault 2006-10-30 13:08:13 EST
Tested on same phyical host under the i386 version and I find the same problem
occurs.

I can provide anything you need to help debug this problem
Comment 2 Stephen Tweedie 2006-10-30 19:03:43 EST
Please give us some basic information about your network config.  Without that
we cannot help at all; networking is working fine under -xen on multiple test
boxes for me.  Thanks!
Comment 3 deneault 2006-10-31 11:20:46 EST
I honestly have no idea what to tell you or what you'd like to see.  I'm
connected on eth0 to my network(Eth0 uses the bnx2 module) and if the Xen daemon
is off, I can DHCP and everything works fine.  I get an IP. I can ping. 
Everything works.

If I start the xen daemon, evertything stops working.  I lose my IP address on
eth0.  I see no traffic on eth0 via tcpdump.  If I turn off the xend service and
down/up the interfaces, things do not return to normal.  No other interfaces
work either.

I've even tried plugging in a USB NIC to see if it was a driver problem with the
built-in NICs and it doesn't work either.  IPtables and selinux are both off.

Let me know specifically what would help and I'll get it to you.  I can give you
access to the host if you'd like as well.
Comment 4 Daniel Berrange 2006-10-31 11:40:04 EST
Some general info about your networking configuration. To start with the output
from the follows commands would be useful:

ifconfig -a
route -n
sysctl -a
iptables -L -n -a

If you can get this info before and after strarting the xend service, that'd be
even better.
Comment 5 deneault 2006-10-31 12:19:08 EST
Created attachment 139874 [details]
requested information about problem
Comment 6 Andreas M. Kirchwitz 2006-11-02 06:25:02 EST
Created attachment 140102 [details]
ifconfig -a
Comment 7 Andreas M. Kirchwitz 2006-11-02 06:25:58 EST
Created attachment 140103 [details]
route -n (IPv4)
Comment 8 Andreas M. Kirchwitz 2006-11-02 06:27:09 EST
Created attachment 140104 [details]
route -A inet6 -n (IPv6)
Comment 9 Andreas M. Kirchwitz 2006-11-02 06:28:18 EST
Created attachment 140105 [details]
sysctl -a
Comment 10 Andreas M. Kirchwitz 2006-11-02 06:29:55 EST
Networking problems under Xen are not only 64-bit related,
because on my Pentium 4 (i686) workstation I also have networking
troubles.

My workstation is configured for DHCP, and IPv4 works as expected.
But IPv6 is broken. I get a Link local address, and a Global IPv6
address (of course, both of them work). But I cannot get anywhere
outside of my box with IPv6, even not to other IPv6 machines on the
same network. Tested with ping (ICMP) and ssh (TCP).

With the old-school non-Xen kernel (i686), everything is fine.

(sorry, I better should have archived the attachments into one file)
Comment 11 deneault 2006-11-14 09:55:41 EST
This problem is not fixed by the kernel-2.6.18-1.2849 xen kernel.
Comment 13 Herbert Xu 2006-11-20 20:21:55 EST
This is the same issue as #204534 which is on its way to being resolved.
Comment 14 deneault 2006-11-21 13:09:07 EST
Super!  Except that noone can see that bug.  Is it possible to get a short
description what the problem is?  Kernel?  Xen? Somewhere in between?

Thanks
Comment 15 Stephen Tweedie 2006-11-21 17:37:15 EST
It's a core kernel bnx2 driver firmware bug that is triggered by Xen's bridging
setup.
Comment 16 Simon Clifford 2006-12-21 11:02:06 EST
FYI I have identical behaviour to the submitter on an Opteron system with Tigon
network interfaces (Tigon3 [partno BCM95721], Rev 401, PHY(5750), PCI Express
10/100/1000Base T).
Comment 17 Herbert Xu 2006-12-21 22:52:06 EST
Created attachment 144248 [details]
[BNX2]: Fix Xen problem.

This patch will appear in 2.6.20.

    [BNX2]: Fix Xen problem.

    This fixes the problem of not receiving packets in the Xen bridging
    environment.  The Xen script sets the device's MAC address to
    FE:FF:FF:FF:FF:FF and puts the device in promiscuous mode.	The
    firmware had problem receiving all packets in this configuration.

    New firmware and setting the PROM_VLAN bit when in promiscuous mode
    will fix this problem.

    Signed-off-by: Michael Chan <mchan@broadcom.com>
    Signed-off-by: David S. Miller <davem@davemloft.net>
Comment 18 Herbert Xu 2006-12-21 23:46:50 EST
The rawhide kernel now has 2.6.20-rc1 which contains the fix.
Comment 19 Herbert Xu 2006-12-21 23:57:06 EST
*** Bug 220454 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.