Bug 215227

Summary: Boot stalls at "Loading stage 2.." after a fresh install
Product: [Fedora] Fedora Reporter: Michael Jørgensen <mij>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Severity: high Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: All   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-11-12 16:40:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michael Jørgensen 2006-11-12 16:39:00 UTC
Description of problem:
After installing FC6 from the CD's, the machine won't boot from the harddisk.

Version-Release number of selected component (if applicable):

How reproducible:
Always. I have found no work-around, and therefore the severity is set to 
High. I really need some kind of work-around, so that I at least can boot my 

Steps to Reproduce:
1. Install FC6 from the CD's.
Actual results:
After rebooting, the machine halts with the message "GRUB Loading stage2.."

Expected results:
The machine should boot normally.

Additional info:
This problem has been seen before. However, the solutions presented in the 
other bug reports have not helped me.

I've tried the following:
1. Boot from rescue CD
2. chroot /mnt/sysimage
3. grub-install /dev/sda
However, after booting the machine now hangs at "GRUB Loading stage1.5."

I then tried:
4. Boot from rescue CD
5. chroot /mnt/sysimage
6. /sbin/grub
7.   root (hd0,0)
8.   kernel /boot/vmlinuz-2.6.18-1.2798.fc6 ro root=LABEL=/ rhgb quiet
9.   initrd /boot/initrd-2.6.18-1.2798.fc6.img
but this gives "Error 28: Selected item cannot fit into memory".

My machine details are as follows:
Via EPIA EN12000E motherboard with a VIA VT8237R controller.
512 MB RAM
A single 160 GB SATA disk (no raid).

The partition info is as follows:
sh-3.1#sfdisk -l /dev/sda

Disk /dev/sda: 19457 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/sda1   *      0+    608     609-   4891761   83  Linux
/dev/sda2        609    1217     609    4891792+  83  Linux
/dev/sda3       1218    1340     123     987997+  82  Linux swap / Solaris
/dev/sda4       1341   19456   18116  145516770    5  Extended
/dev/sda5       1341+   1949     609-   4891761   83  Linux
/dev/sda6       1950+   6205    4256-  34186288+  83  Linux
/dev/sda7       6206+  19456   13251- 106438626   83  Linux

/dev/sda1 on / type ext3 (rw,defaults)
/dev/sda2 on /home type ext3 (rw,defaults)
/dev/sda6 on /p2p type ext3 (rw,defaults)
proc on /proc type proc (rw,defaults)
/dev/sda7 on /share type ext3 (rw,defaults)
sysfs on /sys type sysfs (rw,defaults)
/dev/sysfs on /sys type sysfs (rw,defaults)
/dev/sda5 on /var type ext3 (rw,defaults)

The GRUB configuration files are:
sh-3.1#cat /boot/grub/grub.conf
# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,0)
#          kernel /boot/vmlinuz-version ro root=/dev/sda1
#          initrd /boot/initrd-version.img
title Fedora Core (2.6.18-1.2798.fc6)
	root (hd0,0)
	kernel /boot/vmlinuz-2.6.18-1.2798.fc6 ro root=LABEL=/ rhgb quiet
	initrd /boot/initrd-2.6.18-1.2798.fc6.img

sh-3.1#cat /boot/grub/device.map
# this device map was generated by anaconda
(hd0)     /dev/sda

I've tried installing FC5 as well as FC3 onto the same system, but that didn't 
help. I've not yet tried FC2. Nor have I tried installing onto a PATA drive.

Please let me know if there is something else I can try, or some information I 
can provide.

Comment 1 Michael Jørgensen 2006-11-12 16:40:29 UTC

*** This bug has been marked as a duplicate of 215226 ***