Bug 215226 - Boot stalls at "Loading stage 2.." after a fresh install
Boot stalls at "Loading stage 2.." after a fresh install
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
: 215227 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-12 11:38 EST by Michael Jørgensen
Modified: 2008-05-06 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:47:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Jørgensen 2006-11-12 11:38:20 EST
Description of problem:
After installing FC6 from the CD's, the machine won't boot from the harddisk.

Version-Release number of selected component (if applicable):


How reproducible:
Always. I have found no work-around, and therefore the severity is set to 
High. I really need some kind of work-around, so that I at least can boot my 
system.

Steps to Reproduce:
1. Install FC6 from the CD's.
  
Actual results:
After rebooting, the machine halts with the message "GRUB Loading stage2.."

Expected results:
The machine should boot normally.

Additional info:
This problem has been seen before. However, the solutions presented in the 
other bug reports have not helped me.

I've tried the following:
1. Boot from rescue CD
2. chroot /mnt/sysimage
3. grub-install /dev/sda
However, after booting the machine now hangs at "GRUB Loading stage1.5."

I then tried:
4. Boot from rescue CD
5. chroot /mnt/sysimage
6. /sbin/grub
7.   root (hd0,0)
8.   kernel /boot/vmlinuz-2.6.18-1.2798.fc6 ro root=LABEL=/ rhgb quiet
9.   initrd /boot/initrd-2.6.18-1.2798.fc6.img
but this gives "Error 28: Selected item cannot fit into memory".

My machine details are as follows:
Via EPIA EN12000E motherboard with a VIA VT8237R controller.
512 MB RAM
A single 160 GB SATA disk (no raid).

The partition info is as follows:
sh-3.1#sfdisk -l /dev/sda

Disk /dev/sda: 19457 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/sda1   *      0+    608     609-   4891761   83  Linux
/dev/sda2        609    1217     609    4891792+  83  Linux
/dev/sda3       1218    1340     123     987997+  82  Linux swap / Solaris
/dev/sda4       1341   19456   18116  145516770    5  Extended
/dev/sda5       1341+   1949     609-   4891761   83  Linux
/dev/sda6       1950+   6205    4256-  34186288+  83  Linux
/dev/sda7       6206+  19456   13251- 106438626   83  Linux

sh-3.1#mount
/dev/sda1 on / type ext3 (rw,defaults)
/dev/sda2 on /home type ext3 (rw,defaults)
/dev/sda6 on /p2p type ext3 (rw,defaults)
proc on /proc type proc (rw,defaults)
/dev/sda7 on /share type ext3 (rw,defaults)
sysfs on /sys type sysfs (rw,defaults)
/dev/sysfs on /sys type sysfs (rw,defaults)
/dev/sda5 on /var type ext3 (rw,defaults)

The GRUB configuration files are:
sh-3.1#cat /boot/grub/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,0)
#          kernel /boot/vmlinuz-version ro root=/dev/sda1
#          initrd /boot/initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.18-1.2798.fc6)
	root (hd0,0)
	kernel /boot/vmlinuz-2.6.18-1.2798.fc6 ro root=LABEL=/ rhgb quiet
	initrd /boot/initrd-2.6.18-1.2798.fc6.img

sh-3.1#cat /boot/grub/device.map
# this device map was generated by anaconda
(hd0)     /dev/sda

I've tried installing FC5 as well as FC3 onto the same system, but that didn't 
help. I've not yet tried FC2. Nor have I tried installing onto a PATA drive.

Please let me know if there is something else I can try, or some information I 
can provide.
Comment 1 Michael Jørgensen 2006-11-12 11:40:41 EST
*** Bug 215227 has been marked as a duplicate of this bug. ***
Comment 2 Michael Jørgensen 2006-11-13 05:42:46 EST
After a fresh install of FC6 (and verifying that the boot stops after "Loading 
stage2.." I physically moved the SATA disk to a Dell dimenstion 9150 computer 
I recently bought. Here the system boots and loads the kernel, but fails to 
mount the root file system, presumably because of incorrect SATA drivers.

The driver loading by the Fedora installation is sata_via.

Then I replaced the SATA disk with a PATA disk in my original system and 
reinstalled FC6. This time the systems boots fine.
Comment 3 Michael Jørgensen 2006-11-13 05:46:50 EST
Going back to the SATA disk (where it stops at Loading stage2..), I tried 
going into rescue mode and then
1. chroot /mnt/sysimage
2. /sbin/grub
3.   configfile /boot/grub/grub.conf
This once again presents me with the "Error 28: Selected item cannot fit into 
memory".

The I tried getting GRUBs memory information:
grub> displaymem
EISA Memory BIOS Interface is present
Address Map BIOS Interface is present
Lower memory: 640K, Upper memory (to first chipset hole): 3072K
[Address Range Descriptor entries immediately follow (values are 64-bit)]
Usable RAM:  Base Address:  0x0 X 4GB + 0x0,
Length:   0x0 X 4GB + 0xa0000 bytes
Reserved:  Base Address:  0x0 X 4GB + 0xa0000,
Length:   0x0 X 4GB + 0x60000 bytes
Usable RAM:  Base Address:  0x0 X 4GB + 0x100000,
Length:   0x0 X 4GB + 0x300000 bytes
grub>

Don't know if that is useful.
Comment 4 Michael Jørgensen 2006-11-13 05:52:11 EST
Workaround found!

I followed the suggestion in 
<http://forums.fedoraforum.org/forum/showthread.php?t=108936>
and changed the setting in the BIOS for SATA mode from RAID to IDE.

This has solved my problem.

However, I still believe there are several issues with GRUB/anaconda. Firstly, 
the error reporting is terrible. It was pure luck that brought me to the 
solution mentioned above. This has cost me (and other people) many hours of 
debugging. Presumably the anaconda installation could check for "incorrect" 
BIOS settings, or someone should write a note about it in the release notes.

Secondly, what if I *did* need raid support? Surely, it is not acceptable to 
say that hardware raid is not supported.
Comment 5 Bug Zapper 2008-04-04 00:37:14 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 6 Bug Zapper 2008-05-06 12:47:24 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.