Bug 21720

Summary: Remove gcc-2.96-54 / Install gcc-2.95.2
Product: [Retired] Red Hat Linux Reporter: Need Real Name <josephx.e.meier>
Component: gccAssignee: Jakub Jelinek <jakub>
Status: CLOSED NOTABUG QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0CC: tom
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-12-04 23:52:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2000-12-04 23:52:13 UTC
What is the procedure for removing gcc-2.96-54 and installing gcc-2.95.2? 
I have seen nothing but flames about how it shouldn't have been released,
but nothing specific about correcting the problem.  My company "needs" to
have gcc-2.95.2 and they "want" RH7.0.  Unfortunately there seems to be no
straight-forward way to do this.  Installing RPMs from RH6.2 generates all
sorts of errors on compilation of qt-2.2.1 and doing a make bootstrap on
gcc-2.95.2 generates an error [all-target-libio] Error 2.  Everything I
have tried has failed in getting gcc-2.95.2 to function properly under
RH7.0.  I have had some errors similar to Bug 19285 ('struct streampos'
used where a 'int' was expected).
The libio error makes me think that RH doesn't have the libraries where
they should be, but where (and what are) they?  glibc is installed on this
system.

Thanks
Joseph Meier

Comment 1 Jakub Jelinek 2000-12-05 09:39:59 UTC
Vanilla gcc 2.95.2 cannot cope with glibc 2.2 headers, use
http://gcc.gnu.org/install/glibc-2.2.patch
patch.

Comment 2 Tom Gwozdz 2000-12-20 21:06:47 UTC
Are RPMS available for the patched downgraded gcc 2.95.2?

Comment 3 Jakub Jelinek 2000-12-21 09:52:37 UTC
No (at least not released by Red Hat).