Bug 218542

Summary: Frequency scaling support on Athlon (K7) systems doesn't work
Product: [Fedora] Fedora Reporter: Jarod Wilson <jarod>
Component: cpuspeedAssignee: Jarod Wilson <jarod>
Status: CLOSED CANTFIX QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6CC: mark
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-12-06 12:40:12 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 215813    
Bug Blocks:    

Description Jarod Wilson 2006-12-05 17:14:39 EST
Creating a new bug to track this, as the old one was initially a different
problem and has already been closed as a dupe.

+++ This bug was initially created as a clone of Bug #215813 +++

Description of problem:
the module acpi-cpufreq.ko is not present and to the cpuspeed it is need .
I was wayting for new kernel and now with the 2.6.18-1.2849.fc6 kernel it is the
same. For Notbook it is a big problem because it make it very hot

Version-Release number of selected component (if applicable):
2.6.18-1.2798.fc6
2.6.18-1.2849.fc6

How reproducible:
evry time

Steps to Reproduce:
#/etc/init.d/cpuspeed
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-1.2849.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device
  
Actual results:


Expected results:


Additional info:
Was Find in FC5

-- Additional comment from delaigue.cyril@gmail.com on 2006-11-16 10:39 EST --
It was a bad version of the kernel.

Change the version of the kernel (i586 to i686) kernel and it work find.


i have done :

yum install yum-utils
yumdownloader kernel-2.6.18-1.2849.fc6.i686
rpm -Uvh --replacefiles --replacepkgs kernel-2.6.18-1.2849.fc6.i686.rpm

*** This bug has been marked as a duplicate of 211941 ***

-- Additional comment from mark@mjfrazer.org on 2006-12-05 15:54 EST --
I do not think this is related to the kernel version problem with anaconda.

I have fixed my kernel from i586 to i686 and still am seeing this problem.

[root@pacific ~]# /etc/init.d/cpuspeed start
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-1.2849.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device
[root@pacific ~]# uname -a
Linux pacific.mjfrazer.org 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:45:28 EST 2006
i686 athlon i386 GNU/Linux
[root@pacific ~]# find /lib/modules -name acpi-cpufreq.ko
/lib/modules/2.6.18-1.2849.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko
/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko
[root@pacific ~]# 
[root@pacific ~]# rpm -q --qf '%{name} %{version} %{release} %{arch}\n' kernel
kernel 2.6.18 1.2798.fc6 i586
kernel 2.6.18 1.2849.fc6 i686


-- Additional comment from jwilson@redhat.com on 2006-12-05 16:23 EST --
Please try updating cpuspeed to the version in updates-testing, this should stop
acpi-cpufreq from trying to load on systems where it isn't properly supported.

-- Additional comment from mark@mjfrazer.org on 2006-12-05 16:27 EST --
Indeed it does.  Are athlon processors no longer supported for cpu frequency
scalnig?

-- Additional comment from jwilson@redhat.com on 2006-12-05 16:46 EST --
Athlon procs aren't supported by acpi-cpufreq, but they are supported by
powernow-k7. Edit /etc/cpuspeed.conf and set DRIVER accordingly (I believe all
you should have to do is uncomment a line already in there), then restart
cpuspeed and I think you should be good to go.

(most?) k7 systems don't properly populate sysfs with cpufreq info via
/sys/devices/system/cpu/cpu*/cpufreq/scaling_driver). I suppose we could fall
back to looking elsewhere (like /proc/cpuinfo) and try loading powernow-k7, but
I dunno if there are potential pitfalls w/doing something like that...

-- Additional comment from jwilson@redhat.com on 2006-12-05 16:57 EST --
Eep. I don't know what I'm thinking... Don't set DRIVER, because powernow-k7 is
built into the kernel, its not a module... Okay, so I'm not sure what the
correct solution is at the moment. I'll get back to ya on this one, poking at an
athlon box now...
Comment 1 Jarod Wilson 2006-12-06 11:18:03 EST
Okay, I've talked this over a bit internally... Basically, AMD just didn't get
it wrt cpu frequency scaling until the AMD64 line. Only a few Athlon K7 systems,
primarily laptops, actually have functional support for cpu frequency scaling.
The chip has to properly support it (most mobile athlons do, most desktop athon
procs do not), but the motherboard bios must also support it, so putting a
mobile chip in a desktop won't necessarily help.

If your system does properly support cpu frequency scaling, your dmesg output
upon boot should have a message prefixed "powernow-k7: " that gives some
indication of this, and /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver
*should* be present... If you've got one or the other, there may be something we
need to fix, but otherwise, this is a hardware problem that we can't fix.

If you could attach dmesg output from just after boot and show the output of 'ls
-l /sys/devices/system/cpu/cpu*/cpufreq/', it should tell us whether or not
there's anything that can be done here.
Comment 2 Mark Frazer 2006-12-06 12:35:02 EST
[root@pacific ~]# dmesg | grep -i k7
[root@pacific ~]# grep -i k7 /var/log/messages
[root@pacific ~]# ls /sys/devices/system/cpu/cpu? 
cache  crash_notes  topology
[root@pacific ~]# 

So, not supported.  And the new cpuspeed package from updates-testing gets rid
of the nag message.
Comment 3 Jarod Wilson 2006-12-06 12:40:12 EST
Okay, closing bug as CANTFIX accordingly, since this is a hardware limitation.