Bug 215813 - (acpi-cpufreq.ko) acpi-cpufreq.ko loose
acpi-cpufreq.ko loose
Status: CLOSED DUPLICATE of bug 211941
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
http://fedoraproject.org/wiki/Bugs/FC...
:
Depends On:
Blocks: 218542
  Show dependency treegraph
 
Reported: 2006-11-15 16:27 EST by delaigue cyril
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-16 10:39:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description delaigue cyril 2006-11-15 16:27:51 EST
Description of problem:
the module acpi-cpufreq.ko is not present and to the cpuspeed it is need .
I was wayting for new kernel and now with the 2.6.18-1.2849.fc6 kernel it is the
same. For Notbook it is a big problem because it make it very hot

Version-Release number of selected component (if applicable):
2.6.18-1.2798.fc6
2.6.18-1.2849.fc6

How reproducible:
evry time

Steps to Reproduce:
#/etc/init.d/cpuspeed
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-1.2849.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device
  
Actual results:


Expected results:


Additional info:
Was Find in FC5
Comment 1 delaigue cyril 2006-11-16 10:39:02 EST
It was a bad version of the kernel.

Change the version of the kernel (i586 to i686) kernel and it work find.


i have done :

yum install yum-utils
yumdownloader kernel-2.6.18-1.2849.fc6.i686
rpm -Uvh --replacefiles --replacepkgs kernel-2.6.18-1.2849.fc6.i686.rpm

*** This bug has been marked as a duplicate of 211941 ***
Comment 2 Mark Frazer 2006-12-05 15:54:19 EST
I do not think this is related to the kernel version problem with anaconda.

I have fixed my kernel from i586 to i686 and still am seeing this problem.

[root@pacific ~]# /etc/init.d/cpuspeed start
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-1.2849.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device
[root@pacific ~]# uname -a
Linux pacific.mjfrazer.org 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:45:28 EST 2006
i686 athlon i386 GNU/Linux
[root@pacific ~]# find /lib/modules -name acpi-cpufreq.ko
/lib/modules/2.6.18-1.2849.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko
/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko
[root@pacific ~]# 
[root@pacific ~]# rpm -q --qf '%{name} %{version} %{release} %{arch}\n' kernel
kernel 2.6.18 1.2798.fc6 i586
kernel 2.6.18 1.2849.fc6 i686
Comment 3 Jarod Wilson 2006-12-05 16:23:23 EST
Please try updating cpuspeed to the version in updates-testing, this should stop
acpi-cpufreq from trying to load on systems where it isn't properly supported.
Comment 4 Mark Frazer 2006-12-05 16:27:55 EST
Indeed it does.  Are athlon processors no longer supported for cpu frequency
scalnig?
Comment 5 Jarod Wilson 2006-12-05 16:46:05 EST
Athlon procs aren't supported by acpi-cpufreq, but they are supported by
powernow-k7. Edit /etc/cpuspeed.conf and set DRIVER accordingly (I believe all
you should have to do is uncomment a line already in there), then restart
cpuspeed and I think you should be good to go.

(most?) k7 systems don't properly populate sysfs with cpufreq info via
/sys/devices/system/cpu/cpu*/cpufreq/scaling_driver). I suppose we could fall
back to looking elsewhere (like /proc/cpuinfo) and try loading powernow-k7, but
I dunno if there are potential pitfalls w/doing something like that...
Comment 6 Jarod Wilson 2006-12-05 16:57:20 EST
Eep. I don't know what I'm thinking... Don't set DRIVER, because powernow-k7 is
built into the kernel, its not a module... Okay, so I'm not sure what the
correct solution is at the moment. I'll get back to ya on this one, poking at an
athlon box now...
Comment 7 Dave Jones 2006-12-18 22:51:19 EST
Unless it's a "mobile athlon", it doesn't support speed scaling.

The powernow-k7 driver also requires that the BIOS set up the relevant tables in
the BIOS. Without these, it won't be able to do anything.
Comment 8 Jarod Wilson 2006-12-19 10:35:45 EST
Whoops, forgot to update this bug. The Athlon powernow-k7 issue was further
addressed in bug 218542.

Note You need to log in before you can comment on or make changes to this bug.