Bug 218965

Summary: yum wants to install i586 kernel on i686 system
Product: [Fedora] Fedora Reporter: Phil Schaffner <p.r.schaffner>
Component: yumAssignee: Jeremy Katz <katzj>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6CC: davide_bolcioni, poelstra, tadej.j
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-25 17:27:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Phil Schaffner 2006-12-08 14:04:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
When attempting to install new kernel on i686 system, yum wants to also install an i586 kernel corresponding to one already installed.  Wanted to install kernel from updates testing so did:

# yum --enable updates-testing install kernel

and in addition to the desired version, yum wanted to install the i586
kernel from core.  Added "--disable core" and got the new kernel I
wanted.  Rebooted and works OK but out of curiosity did

# yum install kernel

and was offered the i586 2849 kernel from updates corresponding to the
i686 version I already have installed:

# rpm -q kernel
kernel-2.6.18-1.2798.fc6.i686
kernel-2.6.18-1.2849.fc6.i686
kernel-2.6.18-1.2860.fc6.i686

# yum install kernel.i686

says "Nothing to do." as would be expected.

Version-Release number of selected component (if applicable):
yum-3.0.1-2.fc6

How reproducible:
Always


Steps to Reproduce:
1. # yum install kernel
2. 
3.

Actual Results:
Rejected i586 kernel offered by yum.

Expected Results:
Should only have offered to install newer kernel of the same arch as the processor and installed kernel.


Additional info:
# uname -a
Linux tabb1.tabb 2.6.18-1.2860.fc6 #1 SMP Tue Dec 5 13:49:49 EST 2006 i686 athlon i386 GNU/Linux
# cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 4
model name      : AMD Athlon(tm) processor
stepping        : 2
cpu MHz         : 1000.116
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36 mmx fxsr syscall mmxext 3dnowext 3dnow up
bogomips        : 2001.43
Comment 1 Tadej Janež 2007-01-12 11:04:40 EST
Same thing happened to me. I had to manually install i686 versions of the kernel.

Additional info about my computer:
[tadej@tlinux-stable ~]$ uname -a
Linux tlinux-stable 2.6.18-1.2869.fc6 #1 SMP Wed Dec 20 14:51:19 EST 2006 i686
i686 i386 GNU/Linux
[tadej@tlinux-stable ~]$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Mobile Intel(R) Pentium(R) 4 - M CPU 1.80GHz
stepping        : 7
cpu MHz         : 1200.000
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe up cid
bogomips        : 2394.32

Versions of concerned components:
[tadej@tlinux-stable ~]$ rpm -q yum rpm kernel
yum-3.0.1-2.fc6
rpm-4.4.2-32
kernel-2.6.18-1.2868.fc6
kernel-2.6.18-1.2869.fc6
Comment 2 Davide Bolcioni 2007-01-24 12:51:08 EST
This also happened to me, although I noticed it only some time after the fact 
so I cannot report about the circumstances at the time of occurrence. However 
I still have

$ rpm -qa --qf "%{NAME}-%{VERSION}-%{RELEASE} %{ARCH}\n" kernel\*
kernel-2.6.19-1.2895.fc6 i686
kernel-2.6.18-1.2869.fc6 i586
kernel-headers-2.6.19-1.2895.fc6 i386

and I replaced kernel 2895 manually, so this definitely occurred for kernel 
2869 and kernel 2895. This is on an old Athlon:

$ cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 2
model name      : AMD Athlon(tm) Processor
stepping        : 1
cpu MHz         : 700.059
cache size      : 512 KB
Comment 3 Seth Vidal 2007-03-21 18:20:13 EDT
*** Bug 233370 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2007-04-25 14:57:01 EDT
What's the contents of /etc/rpm/platform?
Comment 5 Tadej Janež 2007-04-25 16:43:34 EDT
$ cat /etc/rpm/platform
i686-redhat-linux

$ rpm -q yum rpm kernel.i686
yum-3.0.6-1.fc6
rpm-4.4.2-32
kernel-2.6.19-1.2911.6.5.fc6
kernel-2.6.20-1.2925.fc6
kernel-2.6.20-1.2933.fc6
kernel-2.6.20-1.2944.fc6
Comment 6 Jeremy Katz 2007-04-25 17:27:25 EDT

*** This bug has been marked as a duplicate of 211941 ***