This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 220428

Summary: update-mime-database needs to explicitly set umask
Product: [Fedora] Fedora Reporter: Andrew Kroeger <mb6zcpv02>
Component: shared-mime-infoAssignee: Bastien Nocera <bnocera>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-19 10:06:28 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Andrew Kroeger 2006-12-21 02:40:56 EST
Description of problem:
After my initial FC6 install, Evince worked fine for viewing PDFs.  After
installing some FC6 updates (I've updated multiple times, so I'm not sure when
or which update caused the problem) Evince would give me the error "Unhandled
MIME type: applicaion/x-extension-pdf" and would not open the file.  A quick
Google search led me to
http://forums.fedoraforum.org/archive/index.php/t-104477.html, which indicated
one user had the same problem because files under /usr/share/mime were only
readable by root.  I found that my files under /usr/share/mime were also only
root-readable.

Querying the RPM database showed those files were not owned by any RPM, but the
/usr/share/mime directory was owned by shared-mime-info.  Looking at the files
in shared-mime-info, I found update-mime-database, and also found that
update-mime-database is called in the postinstall script.  Further checking
indicated that other RPM install scripts also call update-mime-database.  I run
my system under umask 0077 for all users and finally realized that during one of
the updates I installed, update-mime-database was called from an RPM script and
inherited root's umask, thus creating all files as only root-readable.

To test my theory, I changed root's umask in one of my shells and manually ran
"/usr/bin/update-mime-database /usr/share/mime".  After that run, I checked and
all files under /usr/share/mime were now world-readable.  After manually
removing ~/.local/share/mime, Evince was now able to view PDF files again.

Version-Release number of selected component (if applicable):
shared-mime-info-0.19-1
Comment 1 Bastien Nocera 2007-04-19 10:06:28 EDT

*** This bug has been marked as a duplicate of 195414 ***