Bug 195414 - file ermissions aren't set in package and default to umask
file ermissions aren't set in package and default to umask
Status: CLOSED DUPLICATE of bug 83006
Product: Fedora
Classification: Fedora
Component: shared-mime-info (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bastien Nocera
:
: 220428 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 23:53 EDT by Rob Garth
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 10:25:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Garth 2006-06-14 23:53:23 EDT
Description of problem:


Version-Release number of selected component (if applicable): 0.17-1.fc5.1

How reproducible: When umask is set to 077, and update is applied mime files are
only readable by root


Steps to Reproduce:
1. Set umask
2. apply update
  
Actual results: Certain pplications fail, yelp has a critical failure


Expected results: he RPM should ignore umask settings and install correct
premissions
Comment 1 Rob Garth 2006-07-02 22:14:23 EDT
Latest patch has asme issues. All normal files in /usr/share/mime were
unreadable by users after patching. Please fix.
Comment 2 Bastien Nocera 2007-04-19 10:06:30 EDT
*** Bug 220428 has been marked as a duplicate of this bug. ***
Comment 3 Bastien Nocera 2007-04-19 10:25:54 EDT
Looks like a problem with rpm as a whole to me. Feel free to reopen the original
bug report if you think you might have more luck convincing the engineer :)

*** This bug has been marked as a duplicate of 83006 ***

Note You need to log in before you can comment on or make changes to this bug.