Bug 2229420

Summary: xdg-desktop-portal-1.17.2 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: xdg-desktop-portalAssignee: David King <amigadave>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: amigadave, debarshir, gnome-sig, jadahl
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: xdg-desktop-portal-1.17.2-1.fc39 Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-09-18 16:22:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
Update to 1.17.1 (#2229420)
none
Update to 1.17.2 (#2229420) none

Description Upstream Release Monitoring 2023-08-05 21:28:24 UTC
Releases retrieved: 1.17.0
Upstream release that is considered latest: 1.17.0
Current version/release in rawhide: 1.16.0-4.fc39
URL: https://github.com/flatpak/xdg-desktop-portal/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/11089/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/xdg-desktop-portal

Comment 1 Upstream Release Monitoring 2023-08-05 21:28:28 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['git', 'commit', '-a', '-m', 'Update to 1.17.0 (#2229420)']' returned non-zero exit status 1.

StdOut:
On branch rawhide
Your branch is up to date with 'origin/rawhide'.

nothing to commit, working tree clean


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 185, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2023-08-29 01:15:06 UTC
Releases retrieved: 1.17.1
Upstream release that is considered latest: 1.17.1
Current version/release in rawhide: 1.17.0-3.fc40
URL: https://github.com/flatpak/xdg-desktop-portal/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/11089/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/xdg-desktop-portal

Comment 3 Upstream Release Monitoring 2023-08-29 01:15:10 UTC
Created attachment 1985751 [details]
Update to 1.17.1 (#2229420)

Comment 4 Upstream Release Monitoring 2023-08-29 01:22:23 UTC
the-new-hotness/release-monitoring.org's scratch build of xdg-desktop-portal-1.17.1-1.fc38.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=105463676

Comment 5 Upstream Release Monitoring 2023-09-01 23:37:21 UTC
Releases retrieved: 1.17.2
Upstream release that is considered latest: 1.17.2
Current version/release in rawhide: 1.17.0-3.fc40
URL: https://github.com/flatpak/xdg-desktop-portal/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/11089/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/xdg-desktop-portal

Comment 6 Upstream Release Monitoring 2023-09-01 23:37:29 UTC
Created attachment 1986643 [details]
Update to 1.17.2 (#2229420)

Comment 7 Upstream Release Monitoring 2023-09-01 23:44:20 UTC
the-new-hotness/release-monitoring.org's scratch build of xdg-desktop-portal-1.17.2-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=105637086

Comment 8 Fedora Update System 2023-09-14 20:12:54 UTC
FEDORA-2023-dc4189d359 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-dc4189d359

Comment 9 Fedora Update System 2023-09-15 02:28:42 UTC
FEDORA-2023-dc4189d359 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-dc4189d359`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-dc4189d359

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2023-09-17 15:55:02 UTC
FEDORA-2023-c4afd3fba8 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-c4afd3fba8

Comment 11 Fedora Update System 2023-09-18 02:04:56 UTC
FEDORA-2023-c4afd3fba8 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-c4afd3fba8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-c4afd3fba8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2023-09-18 16:22:00 UTC
FEDORA-2023-c4afd3fba8 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.