This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 223704

Summary: krb5: non-failsafe install-info use in scriptlets
Product: [Fedora] Fedora Reporter: Ville Skyttä <ville.skytta>
Component: krb5Assignee: Nalin Dahyabhai <nalin>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideKeywords: EasyFix, Patch
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-01-23 12:03:18 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Make install-info use in scriptlets failsafe none

Description Ville Skyttä 2007-01-21 15:47:31 EST
krb5's install-info use in scriptlets is not failsafe, fix attached.  More info:
http://www.redhat.com/archives/fedora-maintainers/2007-January/msg00017.html
Comment 1 Ville Skyttä 2007-01-21 15:47:31 EST
Created attachment 146127 [details]
Make install-info use in scriptlets failsafe
Comment 2 Nalin Dahyabhai 2007-01-22 14:53:25 EST
For future reference, what's the rule here?  If we call install-info last, we
explicitly return 0, or is it that we need to if we call install-info at all?
Comment 3 Ville Skyttä 2007-01-23 12:01:52 EST
The scriptlet's exit code is the one of the last command executed in it, and
execution does not (as of now) stop if an intermediate command returns non-zero.
 So if there are commands after install-info that are not known to fail in
"normal" situations (such as %_excludedocs or read-only /usr/share), an explicit
zero exit code is not needed.
Comment 4 Ville Skyttä 2007-01-23 12:03:18 EST
Oh, and this seems to be fixed in CVS, thanks.