Bug 2238509 (CVE-2023-4504)

Summary: CVE-2023-4504 cups, libppd: Postscript Parsing Heap Overflow
Product: [Other] Security Response Reporter: ybuenos
Component: vulnerabilityAssignee: Product Security <prodsec-ir-bot>
Status: NEW --- QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: security-response-team, zdohnal
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
A vulnerability was found in OpenPrinting CUPS. The security flaw occurs due to failure in validating the length provided by an attacker-crafted CUPS document, possibly leading to a heap-based buffer overflow and code execution.
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2239850, 2239851, 2239852    
Bug Blocks: 2238512    

Description ybuenos 2023-09-12 10:07:17 UTC
Due to failure in validating the length provided by an attacker-crafted CUPS document, CUPS version v2.5b1 and prior, by default, is susceptible 
to a heap-based buffer overflow, and possibly code execution. This CVE appears to be an instance of CWE-122, a heap-based buffer overflow.

Comment 4 Sandipan Roy 2023-09-20 14:00:49 UTC
Created cups tracking bugs for this issue:

Affects: fedora-37 [bug 2239851]
Affects: fedora-38 [bug 2239852]


Created libppd tracking bugs for this issue:

Affects: fedora-38 [bug 2239850]