Bug 225918

Summary: Merge Review: iso-codes
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Ville Skyttä <ville.skytta>
Status: CLOSED RAWHIDE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: caillon, mclasen, mcrha, petersen, pnemade, redhat-bugzilla, roozbeh
Target Milestone: ---Flags: ville.skytta: fedora-review+
petersen: fedora-cvs+
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-23 14:56:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
Update to 3.3, address remaining items
Take 2 none

Description Nobody's working on this, feel free to take it 2007-01-31 19:07:53 UTC
Fedora Merge Review: iso-codes

Initial Owner: dsantani@redhat.com

Comment 1 Roozbeh Pournader 2007-02-04 02:39:41 UTC
Partial review:

* %{_datadir}/locale/*/LC_MESSAGES/*.mo is used instead of find_lang. See:

* Add dependency on pkgconfig to -devel package.

* Don't use %makeinstall. See:

* Either own /usr/share/xml, or depend on xml-common.

* The ISO standards named in description should be changed to their proper name,
"ISO 639" (instead of "ISO-639"), "ISO 3166-1" (instead of "ISO-3166"), and "ISO
3166-2" (instead of "ISO-3166-2").

* Consider using new upstream version (1.0a is available from:

* No need to use %{__mv} and %{__rm}. Use normal mv and rm.

* Use "make %{?_smp_mflags}"

* Add a dot at the end of -devel's description.

* Could do

Instead of:
%dir %{_datadir}/iso-codes

Comment 2 Matthias Clasen 2007-08-11 02:55:44 UTC
All the material objections have been taken care of.

Comment 3 Matthias Clasen 2007-08-31 17:51:40 UTC
Stalled review, needs a new reviewer to give the rubber stamp.

Comment 4 Ville Skyttä 2008-09-20 13:47:05 UTC
Created attachment 317286 [details]
Update to 3.3, address remaining items

Here's a patch that updates to 3.3, addresses remaining comments and removes the unneeded debug_package override.

Comment 5 Matthias Clasen 2008-09-21 04:26:54 UTC
Why is the debug_package override unnecessary ?

Comment 6 Ville Skyttä 2008-09-21 05:30:28 UTC
It's a no-op for noarch packages, see "rpm -E %debug_package".

Comment 7 Matthias Clasen 2008-09-21 21:12:59 UTC
Ah, ok. If you want to go for accuracy in the description, I'd propose to remove the reference to "po format", since the .po files are only in the source package, the binary package contains mo files.

The patch looks fine to me, please go ahead and apply it and rebuild.

Comment 8 Ville Skyttä 2008-09-22 15:15:43 UTC
Created attachment 317375 [details]
Take 2

I tried to, but was denied by CVS ACLs:

**** Access denied: scop is not in ACL for rpms/iso-codes/devel

The 3.3 tarball has been uploaded and the complete patch with fine tuned description is attached.

Comment 9 Matthias Clasen 2008-09-22 15:31:34 UTC
I guess you need to ask parag to open it up, he seems to be the maintainer...

Comment 10 Ville Skyttä 2008-09-22 18:49:39 UTC
I don't particularly need commit access to this package at the moment, and opening it up for the "uberpackager" group will happen when it'll happen (https://www.redhat.com/archives/fedora-announce-list/2008-August/msg00007.html), but meanwhile if someone can commit the patch, we could get this merge review out of the list of open ones...

Comment 11 Parag Nemade 2008-09-23 08:33:17 UTC
   I have opened ACLs now. Feel free to commit your patch as I am unable to download new source release 3.3. I see ftp release directory contains no release tarballs now. looks like upstream ftp maintainance issue to me.

Comment 12 Ville Skyttä 2008-09-23 14:56:23 UTC
Thanks, done and built, closing as approved: http://koji.fedoraproject.org/koji/taskinfo?taskID=838912

I've had some trouble getting a file listing from the upstream FTP site as well but it worked for me a few minutes ago with Firefox.  I've never succeeded to download the tarball with wget but got it every time with curl (could be related to file listing issues, dunno).

Comment 13 Parag Nemade 2008-12-10 04:53:45 UTC
Package Change Request
Package Name: iso-codes
New Branches: F-8 F-9 F-10 devel
Owners: caillon pnemade

Comment 14 Jens Petersen 2008-12-10 05:33:18 UTC
cvs admin done

(Chris said he would like to be recognised as the formal package owner and have Parag as comaintainer.
BTW there are already a lot of comaintainers in the desktop group - dunno if it is really necessary to list them all...?)

Comment 15 Milan Crha 2010-03-18 12:08:25 UTC
This bug is still assigned to a review of iso-codes-3.12-1, thus I'm using it:
All seems fine except it's still using %{__rm}. Might not be a problem, but would be nice to have it replaced as mentioned above.

Comment 16 Matthias Clasen 2010-03-18 23:30:27 UTC
Just do it...that kind of cleanup is not worth wasting bugzilla comments on...