Bug 225918 - Merge Review: iso-codes
Merge Review: iso-codes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:07 EST by Nobody's working on this, feel free to take it
Modified: 2010-03-18 19:30 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 10:56:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ville.skytta: fedora‑review+
petersen: fedora‑cvs+


Attachments (Terms of Use)
Update to 3.3, address remaining items (1.58 KB, patch)
2008-09-20 09:47 EDT, Ville Skyttä
no flags Details | Diff
Take 2 (2.29 KB, patch)
2008-09-22 11:15 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:07:53 EST
Fedora Merge Review: iso-codes

http://cvs.fedora.redhat.com/viewcvs/devel/iso-codes/
Initial Owner: dsantani@redhat.com
Comment 1 Roozbeh Pournader 2007-02-03 21:39:41 EST
Partial review:

MUSTFIX:
* %{_datadir}/locale/*/LC_MESSAGES/*.mo is used instead of find_lang. See:
http://fedoraproject.org/wiki/Packaging/Guidelines#locales

* Add dependency on pkgconfig to -devel package.

* Don't use %makeinstall. See:
http://fedoraproject.org/wiki/Packaging/Guidelines#MakeInstall

* Either own /usr/share/xml, or depend on xml-common.

* The ISO standards named in description should be changed to their proper name,
"ISO 639" (instead of "ISO-639"), "ISO 3166-1" (instead of "ISO-3166"), and "ISO
3166-2" (instead of "ISO-3166-2").

SUGGESTIONS:
* Consider using new upstream version (1.0a is available from:
http://ftp.debian.org/debian/pool/main/i/iso-codes/)

* No need to use %{__mv} and %{__rm}. Use normal mv and rm.

* Use "make %{?_smp_mflags}"

* Add a dot at the end of -devel's description.

* Could do
%{_datadir}/iso-codes

Instead of:
%dir %{_datadir}/iso-codes
%{_datadir}/iso-codes/*.tab
Comment 2 Matthias Clasen 2007-08-10 22:55:44 EDT
All the material objections have been taken care of.
Comment 3 Matthias Clasen 2007-08-31 13:51:40 EDT
Stalled review, needs a new reviewer to give the rubber stamp.
Comment 4 Ville Skyttä 2008-09-20 09:47:05 EDT
Created attachment 317286 [details]
Update to 3.3, address remaining items

Here's a patch that updates to 3.3, addresses remaining comments and removes the unneeded debug_package override.
Comment 5 Matthias Clasen 2008-09-21 00:26:54 EDT
Why is the debug_package override unnecessary ?
Comment 6 Ville Skyttä 2008-09-21 01:30:28 EDT
It's a no-op for noarch packages, see "rpm -E %debug_package".
Comment 7 Matthias Clasen 2008-09-21 17:12:59 EDT
Ah, ok. If you want to go for accuracy in the description, I'd propose to remove the reference to "po format", since the .po files are only in the source package, the binary package contains mo files.

The patch looks fine to me, please go ahead and apply it and rebuild.
Comment 8 Ville Skyttä 2008-09-22 11:15:43 EDT
Created attachment 317375 [details]
Take 2

I tried to, but was denied by CVS ACLs:

**** Access denied: scop is not in ACL for rpms/iso-codes/devel

The 3.3 tarball has been uploaded and the complete patch with fine tuned description is attached.
Comment 9 Matthias Clasen 2008-09-22 11:31:34 EDT
I guess you need to ask parag to open it up, he seems to be the maintainer...
Comment 10 Ville Skyttä 2008-09-22 14:49:39 EDT
I don't particularly need commit access to this package at the moment, and opening it up for the "uberpackager" group will happen when it'll happen (https://www.redhat.com/archives/fedora-announce-list/2008-August/msg00007.html), but meanwhile if someone can commit the patch, we could get this merge review out of the list of open ones...
Comment 11 Parag Nemade 2008-09-23 04:33:17 EDT
Ville,
   I have opened ACLs now. Feel free to commit your patch as I am unable to download new source release 3.3. I see ftp release directory contains no release tarballs now. looks like upstream ftp maintainance issue to me.
Comment 12 Ville Skyttä 2008-09-23 10:56:23 EDT
Thanks, done and built, closing as approved: http://koji.fedoraproject.org/koji/taskinfo?taskID=838912

I've had some trouble getting a file listing from the upstream FTP site as well but it worked for me a few minutes ago with Firefox.  I've never succeeded to download the tarball with wget but got it every time with curl (could be related to file listing issues, dunno).
Comment 13 Parag Nemade 2008-12-09 23:53:45 EST
Package Change Request
======================
Package Name: iso-codes
New Branches: F-8 F-9 F-10 devel
Owners: caillon pnemade
Comment 14 Jens Petersen 2008-12-10 00:33:18 EST
cvs admin done

(Chris said he would like to be recognised as the formal package owner and have Parag as comaintainer.
BTW there are already a lot of comaintainers in the desktop group - dunno if it is really necessary to list them all...?)
Comment 15 Milan Crha 2010-03-18 08:08:25 EDT
This bug is still assigned to a review of iso-codes-3.12-1, thus I'm using it:
All seems fine except it's still using %{__rm}. Might not be a problem, but would be nice to have it replaced as mentioned above.
Comment 16 Matthias Clasen 2010-03-18 19:30:27 EDT
Just do it...that kind of cleanup is not worth wasting bugzilla comments on...

Note You need to log in before you can comment on or make changes to this bug.