Bug 22811

Summary: devfs kills /dev/mouse
Product: [Retired] Red Hat Raw Hide Reporter: Alex Yacoub <ayacoub>
Component: gpmAssignee: Preston Brown <pbrown>
Status: CLOSED DUPLICATE QA Contact: David Lawrence <dkl>
Severity: low Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-12-24 17:08:02 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alex Yacoub 2000-12-24 17:08:00 EST
This isn't exactly a gpm problem, but . . .

devfs overlays /dev/mouse and the initscripts and gpm rely on its
existence.  I would recommend changing the /etc/rc.d/init.d/gpm file to
directly reference the right mouse device or adding some magic to kudzu and
the initscripts to write a link at startup.  Another possibility is using
devfsd to make the links, as in:

REGISTER
misc/psaux
CFUNCTION GLOBAL symlink $devname mouse
UNREGISTER
misc/psaux
CFUNCTION GLOBAL unlink mouse

(see bug 22809 for notes on that).  However, if a new mouse is detected,
kudzu would still have to change that link somehow.  Anyway, just a heads
up on that.

This isn't high priority, since devfs isn't going to be in use anytime
soon.  I just like it when the initscripts work without kludging.
Comment 1 Alex Yacoub 2000-12-24 17:11:45 EST
ARG, sorry about the duplicate!

*** This bug has been marked as a duplicate of 22810 ***