Bug 22810 - devfs kills /dev/mouse
devfs kills /dev/mouse
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: gpm (Show other bugs)
1.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
: 22811 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-24 17:07 EST by Alex Yacoub
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-26 17:11:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Yacoub 2000-12-24 17:07:57 EST
This isn't exactly a gpm problem, but . . .

devfs overlays /dev/mouse and the initscripts and gpm rely on its
existence.  I would recommend changing the /etc/rc.d/init.d/gpm file to
directly reference the right mouse device or adding some magic to kudzu and
the initscripts to write a link at startup.  Another possibility is using
devfsd to make the links, as in:

REGISTER
misc/psaux
CFUNCTION GLOBAL symlink $devname mouse
UNREGISTER
misc/psaux
CFUNCTION GLOBAL unlink mouse

(see bug 22809 for notes on that).  However, if a new mouse is detected,
kudzu would still have to change that link somehow.  Anyway, just a heads
up on that.

This isn't high priority, since devfs isn't going to be in use anytime
soon.  I just like it when the initscripts work without kludging.
Comment 1 Alex Yacoub 2000-12-24 17:11:42 EST
*** Bug 22811 has been marked as a duplicate of this bug. ***
Comment 2 Alex Yacoub 2000-12-25 12:47:50 EST
On further inspection, I think kudzu ought to be able to handle devfsd.conf so
that it automatically adds all kinds of links -- /dev/cdrom, /dev/dvd,
/dev/modem, etc., etc.

I also noticed that bugzill messed up my example, so here it is again:

REGISTER misc/psaux CFUNCTION GLOBAL symlink $devname mouse
UNREGISTER misc/psaux CFUNCTION GLOBAL unlink mouse
Comment 3 Bill Nottingham 2000-12-25 23:31:08 EST
Having kudzu munge devfsd.conf when it's not in use would be
somewhat silly.
Comment 4 Alex Yacoub 2000-12-26 17:11:06 EST
But eventually it will have to, I suppose.  Is RedHat planning on eventually
switching over the devfs?  If so, then kudzu needs to be changed.
Comment 5 Preston Brown 2001-01-05 14:36:38 EST
we are not currently planning on supporting devfs.

Note You need to log in before you can comment on or make changes to this bug.