Bug 231603

Summary: Gnome-terminal crashes during startup on compiz/beryl
Product: [Fedora] Fedora Reporter: Mohd Izhar Firdaus Ismail <mohd.izhar.firdaus>
Component: gnome-terminalAssignee: Behdad Esfahbod <behdad>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: gnomeuser, peter, talbotscott
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-12 19:44:16 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Mohd Izhar Firdaus Ismail 2007-03-09 08:42:22 EST
Description of problem:
Gnome-terminal crashes with X Window System invalid parameter attributes error 

launching it from xterm gives this output

The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1093 error_code 8 request_code 72 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Version-Release number of selected component (if applicable):

How reproducible:
very frequently

Steps to Reproduce:
1. run compiz/beryl
2. start gnome-terminal
Actual results:

Expected results:

Additional info:
Comment 1 David Nielsen 2007-03-10 20:28:08 EST
I'm seeing the same on x86_64, there's no stack available when you run it
through gdb so I can't provide additional information to help track it down.

there's a lot of errors like so:

(gnome-terminal:7433): Vte-WARNING **: Can not find appropiate font for characte
r U+ac10.

If you repeatedly attempt to start up gnome-terminal from the menu it will
eventually start but exit without starting bug-buddy at rather random intervals.
Comment 2 Peter Gordon 2007-03-12 01:23:11 EDT
A "me too" here.

This didn't seem to happen when I played with Compiz last week. Was there
anything significant between then and now in gnome-terminal or Compiz that may
be causing this?

Comment 3 Scott Talbot 2007-03-12 10:19:19 EDT
Add to this a (possible) related that windows (not all of them, but most) open
with the title (drag) bar off-screen.  Once dragged below the panel they can't
be moved above it.  (Not checked with beryl, but if compiz is enabled this happens.)
Comment 4 Behdad Esfahbod 2007-03-12 19:44:16 EDT

*** This bug has been marked as a duplicate of 231454 ***