This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 231454 - gnome-terminal crashes
gnome-terminal crashes
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
: 231603 231817 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-08 09:15 EST by Andrew Overholt
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-08 12:34:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 416129 None None None Never

  None (edit)
Description Andrew Overholt 2007-03-08 09:15:49 EST
Description of problem:
gnome-terminal crashes for me but not for root.  This just started happening
after updating to rawhide yesterday.

Version-Release number of selected component (if applicable):
2.17.92-1.fc7.i386

How reproducible:
Always.

Steps to Reproduce:
1. Click gnome-terminal icon
  
Actual results:
Window very briefly shows up and then goes away.

Expected results:
A beautiful gnome-terminal window.

Additional info:
I installed xterm and if I launch gnome-terminal from there, I get:

The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 936 error_code 8 request_code 72 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I can't get anything meaningful out of gdb but perhaps I'm missing some debug
packages or something.
Comment 1 Andrew Overholt 2007-03-08 12:16:00 EST
This seems to be independent of all gnome-terminal settings (in gconf).  The
variable that makes it fail seems to be compiz.  When I have desktop effects
enabled, it fails and when I don't, it doesn't fail.

I will file upstream and close here when I have done so.
Comment 2 Andrew Overholt 2007-03-08 12:34:50 EST
Filed upstream:  http://bugzilla.gnome.org/show_bug.cgi?id=416129
Comment 3 Behdad Esfahbod 2007-03-12 19:44:05 EDT
*** Bug 231817 has been marked as a duplicate of this bug. ***
Comment 4 Behdad Esfahbod 2007-03-12 19:44:30 EDT
*** Bug 231603 has been marked as a duplicate of this bug. ***
Comment 5 sangu 2007-03-19 23:26:12 EDT
Please See : http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=231170
IS this problem  xorg-x11-xserver-1.3.0rc1 bug?

Note You need to log in before you can comment on or make changes to this bug.