Bug 235864

Summary: segfault without a meaningful backtrace
Product: [Fedora] Fedora Reporter: Patrice Dumas <pertusus>
Component: glibcAssignee: Jakub Jelinek <jakub>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: mattdm, mephisto
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: 2.5.90-21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-18 19:07:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
data file that triggers the segfault none

Description Patrice Dumas 2007-04-10 15:37:47 UTC
Description of problem:

I get a segfault with:

plot 'bug.data' using 6:($210-$95) 

I'll attach my data file bug.data.

This is very strange.

Backtrace is:

(gdb) run
Starting program: /usr/bin/gnuplot bug-temp.plt

Program received signal SIGSEGV, Segmentation fault.
*__GI_wmemset (s=0xbf959990, c=48, n=4294964831) at wmemset.c:33
33            wp[0] = c;
(gdb) bt
#0  *__GI_wmemset (s=0xbf959990, c=48, n=4294964831) at wmemset.c:33
#1  0x00b8193b in ___printf_fp (fp=0x30, info=0x30, args=0x30)
    at printf_fp.c:1088
#2  0x00000030 in ?? ()
#3  0x00000030 in ?? ()
#4  0x00000030 in ?? ()
#5  0x00000030 in ?? ()
until infinity.

I tried with FC6 gnuplot, same thing. That's a bit strange
and it may not be a gnuplot bug but an issue with my libs
or something like that. I run fedora devel.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:

Comment 1 Patrice Dumas 2007-04-10 15:38:43 UTC
Created attachment 152147 [details]
data file that triggers the segfault

Comment 2 Matthew Miller 2007-04-10 16:37:03 UTC
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.

Comment 3 Ivana Varekova 2007-04-13 11:29:33 UTC
There seems to be problem with gprintf(util.c) procedure - the segfault happens
when program try to write double variable (x), in format "%g" which should cause
no error. Jakub, could you please look at it.

Comment 4 Jakub Jelinek 2007-04-13 13:00:02 UTC
This is a glibc bug, reproduced with current CVS glibc built for i686, using
union { long long l; double d } u = { .l = 0x3f1a36e2eb1c432cLL };
main (void)
  __builtin_printf ("%g\n", u.d);
  return 0;

Comment 6 Jakub Jelinek 2007-04-16 13:00:37 UTC
*** Bug 236536 has been marked as a duplicate of this bug. ***

Comment 7 Jakub Jelinek 2007-04-18 19:07:32 UTC
Should be fixed in glibc-2.5.90-21.

Comment 8 Mephisto 2007-04-18 22:59:27 UTC
I can confirm my case to be fixed with -21 (bug 236536).

Comment 9 Patrice Dumas 2007-06-02 09:23:35 UTC
Fixed for my case too.