Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.

Bug 238844

Summary: F7T4: Install stalls at "Add additional software repositories" with "Sending request for IP information for eth0..."
Product: [Fedora] Fedora Reporter: Moritz Barsnick <moritz>
Component: anacondaAssignee: David Cantrell <dcantrell>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: fedora
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-22 16:23:37 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 150226    
Attachments:
Description Flags
screenshot of stall none

Description Moritz Barsnick 2007-05-03 07:30:48 EDT
Description of problem:
Installing Fedora 7 Test4 from DVD (f7-test4-i386.torrent).
System: VMware Player with vmwarez.com-Generic-LiveCD-Virtual-Machine (from 
http://www.vmwarez.com/2006/02/livecd-player-virtual-machine.html)
Host: Lenovo T60 running Windows XP SP2 32bit on Intel T2400 (Core Duo)

During initial installation setup, I selected "Add additional software 
repositories". A "popup" came up, saying "Sending request for IP information 
for eth0...". Here, installation stalled forever with a rotating cursor.

Version-Release number of selected component (if applicable):
f7-test4-i386.torrent

How reproducible:


Steps to Reproduce:
1. Run vmwarez.com-Generic-LiveCD-Virtual-Machine with F7T4 DVD in (connected) 
drive, Ethernet "connected" and "bridged".
2. Go through initial installation steps.
3. Select automatic DHCP config for eth0. VMware should provide virtual DHCP on 
the virtual eth0.
3. At the step "The default installation of Fedora includes a set of spftware 
applicable for general internet usage. What additional tasks would you like 
your system to include support for?", select "Office and Productivity" (is 
preselected) and "Software Development".
4. Select "Add additional software repositories".

Actual results:
A "popup" comes up, saying "Sending request for IP information for eth0...". 
The cursor rotates forever. The popup never terminates or times out. The popup 
cannot be stopped, interrupted, escaped.

Expected results:
Installer should initialize eth0 (DHCP query I guess) and ask for proxy 
settings. If DHCP does not work, or network connection fails (for whatever 
reason, e.g. proxy setting assumed done before), the installer should bail out 
and fall back.

Additional info:
I'm assuming anaconda is the correct component to report against. Please 
correct if wrong.

The named virtual machine is made for live CDs/DVDs, but should be generic 
enough to allow an install (from what I've read).
Comment 1 Moritz Barsnick 2007-05-03 07:30:48 EDT
Created attachment 154018 [details]
screenshot of stall
Comment 2 Thorsten Leemhuis 2007-05-05 08:37:10 EDT
saw this also with test4 on vmware-server.i386; according to the dhcpd-logs it
seems dhcpd handed out the ip to the vmware-guest correctly

Configuring eth0 statically worked for me so I could move on. Network worked
normally with dhcp after install finished.
Comment 3 Jeremy Katz 2007-05-21 17:54:25 EDT
Reproduced with rawhide + changes so that we actually try to configure again...
 related to bug 240804
Comment 4 David Cantrell 2007-05-22 16:23:37 EDT

*** This bug has been marked as a duplicate of 240804 ***