Bug 240804 - runtime netconfig is completely and utterly busted
Summary: runtime netconfig is completely and utterly busted
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
: 238080 238844 (view as bug list)
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-05-21 20:30 UTC by Jeremy Katz
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 20:21:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2007-05-21 20:30:19 UTC
All of the runtime network configuration outside of the loader is completely and
utterly busted.

1) Start rescue mode from CD, try to do DHCP, watch things segfault
2) Start install from DVD, select to add additional repos and watch it not ever
try to bring up the network.  The fact that a port has link doesn't mean
anything at all about whether or not there's a working network connection. 
Changing to the FC6 method of checking the IP's validity as well gets to the
config screen, but it never attempts to get a dhcpv4 address and blows up on
static ips.

Comment 1 Jeremy Katz 2007-05-21 21:09:11 UTC
Okay, now have everything dying the same way.  I guess that's some kind of
progress, but still not there.

Comment 2 David Cantrell 2007-05-22 20:21:51 UTC
Bug was in libdhcp4client, so reassigning component.  Fixed in dhcp-3.0.5-35.fc7.

Comment 3 David Cantrell 2007-05-22 20:23:40 UTC
*** Bug 238844 has been marked as a duplicate of this bug. ***

Comment 4 David Cantrell 2007-05-22 20:27:58 UTC
*** Bug 238080 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.