Bug 240268

Summary: nfs-utils-1.0.10-10 postun scriplet failed
Product: [Fedora] Fedora Reporter: Kam Leo <a1tmblwd>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED DUPLICATE QA Contact: Ben Levenson <benl>
Severity: low Docs Contact:
Priority: medium    
Version: 6CC: thoger
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-16 06:47:56 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Kam Leo 2007-05-16 01:38:08 EDT
Description of problem:

Script fails to remove nfs-utils-1.0.10-7.fc6 after update.

Version-Release number of selected component (if applicable):

nfs-utils-1.0.10-10.fc6

How reproducible:

Every time.

Steps to Reproduce:
1. Use yum or smart to update nfs-utils
2.
3.
  
Actual results:
Get error message:

Fetching packages...
-> http://download.fedora.redhat.com/pub/.../nfs-utils-1.0.10-10.fc6.x86_64.rpm
nfs-utils-1.0.10-10.fc6.x86_6.. ######################################## [100%]

                                                                               
Committing transaction...
Preparing...                    ######################################## [  0%]
   1:Installing nfs-utils       ######################################## [ 50%]
   2:Cleaning nfs-utils         ######################################## [100%]
error: %postun(nfs-utils-1.0.10-7.fc6.x86_64) scriptlet failed, exit status 1 
Expected results:


Additional info:
Comment 1 Tomas Hoger 2007-05-16 04:47:24 EDT
Source of the problem seems to be the fact, that /etc/init.d/nfs condrestart
returns 1, when nfs is not runnning.  Test '[ -f /var/lock/subsys/nfs ]' (line
158) is the last command executed and it's return value (1) is than return by
'exit $?' (line 168).

Workaround to get rid of old nfs-utils version:

rpm -e --noscripts nfs-utils-<old-version>
Comment 2 Tomas Hoger 2007-05-16 05:44:37 EDT
This report is duplicate of #240225, which seems to contain all relevant
information provided by bug submitter.
Comment 3 Michael Schwendt 2007-05-16 06:47:56 EDT

*** This bug has been marked as a duplicate of 240225 ***