Bug 240268 - nfs-utils-1.0.10-10 postun scriplet failed
nfs-utils-1.0.10-10 postun scriplet failed
Status: CLOSED DUPLICATE of bug 240225
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-16 01:38 EDT by Kam Leo
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 06:47:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kam Leo 2007-05-16 01:38:08 EDT
Description of problem:

Script fails to remove nfs-utils-1.0.10-7.fc6 after update.

Version-Release number of selected component (if applicable):

nfs-utils-1.0.10-10.fc6

How reproducible:

Every time.

Steps to Reproduce:
1. Use yum or smart to update nfs-utils
2.
3.
  
Actual results:
Get error message:

Fetching packages...
-> http://download.fedora.redhat.com/pub/.../nfs-utils-1.0.10-10.fc6.x86_64.rpm
nfs-utils-1.0.10-10.fc6.x86_6.. ######################################## [100%]

                                                                               
Committing transaction...
Preparing...                    ######################################## [  0%]
   1:Installing nfs-utils       ######################################## [ 50%]
   2:Cleaning nfs-utils         ######################################## [100%]
error: %postun(nfs-utils-1.0.10-7.fc6.x86_64) scriptlet failed, exit status 1 
Expected results:


Additional info:
Comment 1 Tomas Hoger 2007-05-16 04:47:24 EDT
Source of the problem seems to be the fact, that /etc/init.d/nfs condrestart
returns 1, when nfs is not runnning.  Test '[ -f /var/lock/subsys/nfs ]' (line
158) is the last command executed and it's return value (1) is than return by
'exit $?' (line 168).

Workaround to get rid of old nfs-utils version:

rpm -e --noscripts nfs-utils-<old-version>
Comment 2 Tomas Hoger 2007-05-16 05:44:37 EDT
This report is duplicate of #240225, which seems to contain all relevant
information provided by bug submitter.
Comment 3 Michael Schwendt 2007-05-16 06:47:56 EDT

*** This bug has been marked as a duplicate of 240225 ***

Note You need to log in before you can comment on or make changes to this bug.