This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 242219

Summary: Smolt is asking for "y/n" but is expecting "j" at German system
Product: [Fedora] Fedora Reporter: Robert Scheck <redhat-bugzilla>
Component: smoltAssignee: Mike McGrath <mmcgrath>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 8CC: dcantrell, dgunchev, fedora, jeff, ma, triage
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: bzcl34nup
Fixed In Version: smolt-1.1.1.1-3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-04 11:04:51 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235704    
Attachments:
Description Flags
Fix to solve this annoying issue
none
Fix for the same problem in Spanish translation none

Description Robert Scheck 2007-06-02 05:23:11 EDT
Description of problem:
Mike, according to our nice talk about smolt I'm attaching here the tiny patch
to solve the issue we discovered this morning at LinuxTag. Please apply :)

Version-Release number of selected component (if applicable):
smolt-0.9.8.1-1

How reproducible:
Everytime, because smolt is expecting "j" while it's asking for "y/n".
Comment 1 Robert Scheck 2007-06-02 05:23:12 EDT
Created attachment 155971 [details]
Fix to solve this annoying issue
Comment 2 Robert Scheck 2007-06-02 06:00:47 EDT
Created attachment 155972 [details]
Fix for the same problem in Spanish translation
Comment 3 Robert Scheck 2007-06-02 06:03:03 EDT
Please note, that Norwegian translation (nb) is also broken, but I don't know
any native speaker out of the box. A solution would be to change the msgstr of
msgid "y" simply from "j" to "yes":

#: sendProfile.py:108
msgid "Send this information to the Smolt server? (y/n)"
msgstr ""

#: sendProfile.py:109
msgid "y"
msgstr "j"
Comment 4 Robert Scheck 2007-06-02 06:05:46 EDT
Oriya translation (or) is broken the same way, but I'm not using a UTF-8 system
to be able to fix this in a sane way somehow. Easiest (but maybe wrong) would be
to copy the value from the second translation to the first one...

#: sendProfile.py:108
msgid "Send this information to the Smolt server? (y/n)"
msgstr "Smolt ସେବକକ ଏହ ସଚନା ପଠାନତ? (y/n)"

#: sendProfile.py:109
msgid "y"
msgstr "ହ"
Comment 5 Robert Scheck 2007-06-02 06:31:36 EDT
Okay, I've checked now all translations that are provided for smolt. Please also
apply my fix for Spain and have a look to the two others...
Comment 6 Mike McGrath 2007-06-02 07:54:51 EDT
I may just change it so that y is always accepted as well as whatever the local
equivelant is supposed to be.

is this a bad idea?
Comment 7 Robert Scheck 2007-06-02 08:01:27 EDT
I agree with you. Hopefully there is no language where "y" means "no". Finally
my figured out problems should be solved within the translation for a correct
locale.
Comment 8 Robert Scheck 2007-09-02 21:27:15 EDT
Ping?
Comment 9 Martin Jürgens 2007-10-06 07:15:45 EDT
*** Bug 321081 has been marked as a duplicate of this bug. ***
Comment 10 Sebastian Vahl 2007-10-25 04:02:35 EDT
Problem still persists in smolt-0.9.9-1.fc8.
Comment 11 Jesse Keating 2007-10-25 08:53:26 EDT
Moving to target.  We won't hold up the release for this.
Comment 12 Robert Scheck 2007-10-25 09:24:34 EDT
Jesse, this bug has to be fixed anyway! It is a (very) easy fix and I already 
told Mike this one at F7 release which is now nearly 6 months ago!
Comment 13 Jesse Keating 2007-10-25 09:37:26 EDT
I don't disagree that it should be fixed, that's why it's on the Target. 
However at the end of the day we wouldn't hold up the release of Fedora 8 for
this issue.  It just doesn't meet the criteria. 
http://fedoraproject.org/wiki/QA/ReleaseCriteria
Comment 14 Robert Scheck 2007-12-16 08:16:29 EST
Mike! Can you please fix this bug before F9?
Comment 15 Martin Jürgens 2007-12-16 09:18:13 EST
Maybe the easiest way is to just change the translation on
translations.fedoraproject.org..
Comment 16 Robert Scheck 2007-12-16 13:32:30 EST
Yes, that's what I was asking for. See the translation patches.
Comment 17 Mike McGrath 2007-12-16 14:03:56 EST
This was all been fixed a long time ago.  Something is completely fubar with the
current german translation which will likely have to be fixed by the german
translator but the es translation is as it should be:

¿Enviar esta información al servidor Smolt? (s/n)

The german po doesn't seem to be working at all right now.

Robert, what version of smolt are you seeing german translations work at all? 
The latest version doesn't seem to be correct.  smolt-1.0-2.fc7 is what I just
tested with.

Comment 18 Bug Zapper 2008-04-04 06:56:34 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 19 Mike McGrath 2008-04-04 11:04:51 EDT
This does seem to be working now - 

Diese Informationen an den Smolt-Server senden? (j/n) j
Scanning http://www.smolts.org/ for known errata.