Bug 253748

Summary: nas probably shouldn't start by default
Product: [Fedora] Fedora Reporter: Jeremy Katz <katzj>
Component: nasAssignee: Frank Büttner <bugzilla>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-08-29 09:12:22 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235704    

Description Jeremy Katz 2007-08-21 13:52:35 EDT
The nasd service probably shouldn't be enabled by default.  It gets pulled in by
arts (and thus many things), but isn't used without some configuration on the
part of users.  Having it automatically start ends up slowing boot
Comment 1 Frank Büttner 2007-08-26 03:25:19 EDT
For Qt applications that play's sound, an running daemon is needed.
So it is started by default. To reduce lazy bug tickets about missing sound in
Qt apps. 
Comment 2 Jeremy Katz 2007-08-27 11:17:52 EDT
Is arts setup to use nasd by default?  It at least used to just go to alsa by
default.  And for the future, it should probably move towards PulseAudio.  But
sound requiring a system service daemon for it to work at all just sounds like a
bad idea...
Comment 3 Rex Dieter 2007-08-27 11:49:28 EDT
For arts, you're right.  But that's not all.

As Frank alluded, qt/qt4-only apps can use nas to play sound.  If nas isn't
running -> no audio.  qt4 (already) includes nas support, qt(3) could too, it
just hasn't been enabled yet.
Comment 4 Jeremy Katz 2007-08-27 12:02:04 EDT
(In reply to comment #3)
> As Frank alluded, qt/qt4-only apps can use nas to play sound.  If nas isn't
> running -> no audio.  qt4 (already) includes nas support, qt(3) could too, it
> just hasn't been enabled yet.

Can or has to?  Functionality being available is one thing, defaulting to it is
something entirely different.  Especially since NAS only buys you something if
you've actually set it up for remote use which also requires firewall tweaking,
etc... at which point, enabling a service really isn't a big deal.
Comment 5 Rex Dieter 2007-08-27 12:22:00 EDT
For qt-only apps that use it's audio class(es), "has to".  I suppose the set of
qt-only apps using audio is likely small (I can't think of any in fedora
offhand), so we could consider sacrificing them "just working" so nas isn't
started by default for everybody else.
Comment 6 Jeremy Katz 2007-08-28 15:26:10 EDT
(In reply to comment #5)
> For qt-only apps that use it's audio class(es), "has to".  I suppose the set of
> qt-only apps using audio is likely small (I can't think of any in fedora
> offhand), so we could consider sacrificing them "just working" so nas isn't
> started by default for everybody else.

Especially as pre-Fedora 7, we didn't ship NAS in Core, so those apps would have
just been silent then.  Please tell me that qt4 has a better sound backend than
just nas....
Comment 7 Rex Dieter 2007-08-28 16:05:06 EDT
> Please tell me that qt4 has a better sound backend than
> just nas....

None that I'm aware, sorry.  That doesn't mean qt apps can't use something else
like, say, pulseaudio and/or gstreamer...

Anyway, Jeremy has a point here, and I would tend to agree, esp since nas isn't
actually used (by default) by anything in fedora...  Frank?
Comment 8 Frank Büttner 2007-08-29 09:12:22 EDT
No, because the default backed for Qt is nasd, so an running nasd is needed.
Comment 9 Rex Dieter 2007-08-29 09:30:57 EDT
Agreed that it is the default audio backend, but our point is that there is
currently very little value in enabling nasd by default (since, afaik, no apps
in fedora currently use it).  

Perhaps this discussion can/should be taken to fedora-devel or fedora-desktop list?

For example, would be nice if nasd could be turned into a service that starts on
demand (via dbus or whatever).
Comment 10 Rex Dieter 2008-03-21 15:16:16 EDT
fwiw, kde4 (and qt-4.4) will feature Phonon for multimedia support, based on 
xine-lib currently, but will have gstreamer backends soon, hopefully in time 
for F9, if not, shortly thereafter.

See followup to this, bug #438547 , to introduce a -libs pkg split , as a 
compromise to make everyone happy.